• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 507
  • Last Modified:

WebClass Runtime error

I'm using VB to create a web class.
On one machine it works fine,
on another I get a:

WebClass Runtime error '800a9c4a'

An unspecified error has occurred

/Project1/WDI.ASP, line 14

which is the call to my web class:

Application("~WC~WebClassManager").ProcessNoStateWebClass "Project1.WDI", _
            Server, _
            Application, _
            Session, _
            Request, _
            Response
%>

The project does work when I compile it into
a DLL and regsvr32 it.  But that's a tough way
to debug an application :)

Does anybody have any idea?  I can't even find a reference to that error number anywhere.  That would at least get me started...



thx,
-David

0
dpinkus
Asked:
dpinkus
  • 2
1 Solution
 
dpinkusAuthor Commented:
Edited text of question.
0
 
robbertCommented:
You're calling the proc Application("~WC~WebClassManager").ProcessNoStateWebClass, so look in global.asa what Application("~WC~WebClassManager") actually means, and then go further, i.e., comparing registry keys or if files exist.

That your app is working as a DLL does not say anything, because there's no need to call the WebClassManager.
Probably, VB6 isn't installed on the machine AND you did not deploy your app correctly.
0
 
dpinkusAuthor Commented:
VB6 is installed and I did deploy it correctly, and believe it or a not, a reboot fixed it.  Should have tried that first.  Oh well, c'est la vie.  

Thanks, I'll give you the points for at least taking the time to answer this...
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now