Reading Win9x CD-RW format in Linux

So, my friend has a CD-RW on his Windows box, I bought some CD-RWs so that I can transfer files on them, instead of using zip disks. I formated the CD-RW on Windows and when I mount it on my SuSE 6.3 Linux box, the only two files that show up are:
udfinstall.exe (or udfsetup.exe something like that)
I don't see any of the files I wrote on Windows, I am using a Memorex IDE (regular cd drive), model CD-402E, and his CD-RW is HP 9100 series.
Something tells me that the CD-RW format for Windows is meant not to work on any other OS, isn't this the pattern with MS products? I need definite answears on what to do.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Did you try a regular CD-R disc instead.  If not, try that, and be sure to close the session and disk when setting the options under CD Creator.  It may be that your cdrom (Memorex is not the most compliant in the world) cannot read the CDRWs correctly, depending on the format.  Make sure you are mounting your cdrom in iso9660 mode also.
banasw01Author Commented:
Oh, I should mention that I can read any regular CD-R disks I make on Windows or Linux without a problem on my SuSE Linux box with the Memorex drive. I don't think I can "close the session on a CD-RW, because CD-RW does not become CD-R by closing it... I don't think so, because that is the point of CD-RW; never closing it...
I can read the CD-RW in my friends regular drive (in windows), he also has a Memorex drive, IDE (model CD-482E).
And I do mount it as iso9660.

I talked to my friend and he said that you need a patch for Windows 95 if you want to read those CD-RWs, but you don't need a patch for Win98. Maybe I need a patch for Linux, or some special program/driver/something to read this format. I tried searching on the Web, I will also contact HP, by the way, the CD-RW drive is: HP CD-Writer Plus 9100 series. Thank you
biard suggested you to try a CD-R (note the R only, not RW) instead of a CD-RW. That should be a good test.
This does not depend on the CD type (-R / -RW). Rather, it's the format of the data. You have created a UDF (universal disc format) CD. Apparently Linux cannot handle thesse (I have never tried that myself). The two files that you have seen on the CD are some kind of "stub" for systems that do not handle UDF discs properly. Try creating a CD-RW with a regular format. Linux supports the formats ISO9660, RockRidge and Joliet. Look for these formats in your CD burning program.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
banasw01Author Commented:
You are right no the money! Linux cannot handle UDF without a kernel module. The module is included in latest development kernels. I found a place where I got a stand alone module, I compiled it for my kernel 2.2.13 and did "insmod udf.o" and then "mount -t udf /dev/hdc /mnt/cdrom" and I was able to read it no problem! The stand alone module is at:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.