Mounting

I'm running Win98 with fat32
and Linux Redhat 5.2 ext2 file system

I mounted one of my harddives as both msdos and auto and evertime I come back I get scandisk telling me long file error this and that even if I don't touch long file names.  The exact error is that Long file name blabla doesn't match any file so we are going to destroy it.  I don't loose the file but it's othersome.  

Then I mounted a CD and maked an ISO, burned it from Windows and two files were currupt, I think its the CDROM but I'm not sure.
riglinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mzehnerCommented:
First of all, you should not mount a fat32 filesystem as msdos, it should be mounted as vfat.  Read your man page on mount and fstab.  If you are mounting via your "/etc/fstab" file, you can include a line like:
/dev/hda2  /win98  auto  defaults 0 0
Where /win98 is a directory where it will be mounted.  Of course for the first parameter /dev/hda2, substitute your drive information.  Are you using the mount command manually?  I don't know if an incorrect mount could cause your problems, but it may since a dos filesystem doesn't support long filenames.  What mount command are you using?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
biardCommented:
Also, Linux and Windows handle Carriage Return/Line Feed differently in files, so there may be translation broblems causing the files to appear corrupt in Linux.
0
riglinAuthor Commented:
For some reason or another vfat wasn't part of the list of types.  Don't know why, just wasn't there in man, or help.  

Thanks
-Riglin
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.