Disk I/O error during bootup

I am working on an older PC with a Supermicro P55CM motherboard. It has a AMI pentium*PNP ISA bios with date of 1996, and INTEL pentium 100mhz cpu.

At bootup the bios auto dectects the hard drive ok and the AMI bios system config display is followed by the messages: External cache type: pipline burst    Lpt mode: normal

DISK I/O error Replace the disk and press any key..

If I bootup from a floppy, the C drive is allocated to ramdrive and then messages saying it could not detect Win 98 or virus etc. and it then shows the A: prompt

I ran Tufftest diagnostics and they ran ok. The hard disk boots up on other machines.

Got any suggestions, questions, etc.    
dxbrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

OttaCommented:
Enter BIOS-setup, and use "auto-detect IDE hard-drives", to verify that your BIOS has the correct Cylinders/Heads/Sectors settings for your hard-drive.

How large is the hard-drive?
Has it *EVER* worked in this computer?
0
dxbrAuthor Commented:
Yes the bios shows the correct cyls, etc. I tried different hard drives. 540 mb, 1.5gb, etc.

I do not know if the system is original or ? We got it from a surplus sale.

I unpluged and repluged all cards and cables and tried other ribbon cables.

I tried a secondary master on IDE#2 and it detects the drive ok, then after the AMI bios config and LPT mode it just shows a blinking cursor.  

Is there some way to check the motherboard IDE#1 and IDE#2 slots?


 
0
dsazamaCommented:
I would check to see if the IDE controller is bad... Put in a new hard drive and let it auto detect and then fdisk, format, and sys the drive with a DOS floppy.  If the hard drive does not boot after this I would suspect the IDE controller.  If it DOES boot properly it is possible that the hard drive that you are trying to use was fdisked with settings different than the ones listed by the auto settings and / or the label on the hard drive... If that is the case there is not much you can do except let the bios auto detect the settings and start from scratch (losing all of your data)... I hope this helps
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

OttaCommented:
> it just shows a blinking cursor.

Had exactly this problem, yesterday.
The diskette-drive would spin, but it wouldn't read any data, when attempting to read the "boot-sector".  I replaced the diskette-drive.
0
dxbrAuthor Commented:
dsazama;
    I took a HD drive and on another PC I did fdisk and deleted the partition. Then I attached this to the problem PC and booted up with a floppy, and the drive auto-detected ok but it loaded the diagnostic tools on D. When I CD to C: and enter fdisk, a message displays saying: invalid media type reading C

Then if I attach the drive to my good PC, it auto-detects ok but does the same as above. I now cannot fdisk the drive on my good PC?? I get invalid media type on C etc..

I did this with two drives and am now wondering if the problem PC damaged the drives?

Would a PC repair shop have a test card or somthing that could test the IDE controller on the motherboard?  
   
0
dsazamaCommented:
yes, ask them if they have check-it pro or a hardware test tool... this should tell you if something is wrong
0
craigsosebeeCommented:
from your last post it seems that you are trying to access a drive that has no partition on it. You should run fdisk from A: enter fdisk, create a primary partition, make one active if creating more than one, esc out and reboot from A: then use the format command from A: to format C: After this you will be able to SYS c: and copy files to it or install an OS. These are the  following steps:

1. Boot from win98 startup disk or other boot disk
2. At A:
     
         A:/fdisk  [enter]
       
Within fdisk:

     choose option 4 to check existing partition status. If you already have a partition then delete it, ////you will lose all data////

    choose option 1 to create partition; assign all space to it or you will have to create an extended partition with logica drives.

     ESC out after you have created the partition; it will tell you to reboot to use the partition.

3. Reboot the machine from the A:
4. At A:

      format c:   or format c:/s  (if you want to boot directly to C:)

5. you can now access the C: drive to install the OS
     

     


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dxbrAuthor Commented:
craiqsosebee;

Your answer solved my problem. Thanks a lot.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.