• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 295
  • Last Modified:

Novell 3.11 Migration...

I'm migration an old Novell 3.11 Server to WIndows NT, and I'm having a couple of problems putting the old MS-DOS Applications working the way they did on Novell.

One of the problems is a small text editing tools that used to print to Novell's print queues, on mapped printer ports (LPT1, LPT2, LPT3). Now that I put it to work under MS Network (I'm using 'net use LPT1' to map ports), it simply doesn't print. It works like it is printing, but it does nothing. What can that be?

The other problem I have, with that same application and with another one, is that, although they worked fine on Novell with 8 users, on NT, when I try to use the program from 2 Workstations at the same time, I keep getting Sharing Violation messages. Is there any way to solve this problem?

Thanks...
0
rbarradas
Asked:
rbarradas
1 Solution
 
klaszloCommented:
When quiting from app, does it print ?

Try to give only Read permission to share with apps.

Welcome in the world of Microsoft Networking...
0
 
LermitteCommented:
Did you have setup the printers with the print for DOS applications on... in the properties for the printers you find this.

Mario
0
 
Handy HolderSaggar maker's bottom knockerCommented:
Do you have share.exe loaded on the DOS/lanmanager clients?

0
 
rbarradasAuthor Commented:
As for the printing, it does not print, even when I quit the application. I have another client where that happens, although I don't know why.

I'll try the Read permission on the share.

As for the share.exe, I've already tryed to load it, without any results.
0
 
handrichCommented:
Hi rbarradas

I have a maybe not so good answer for you.
First printing:
the net use command captures (as it says ) a lpt device and not a parallel port (378) as the capture command does.
This means if your old software directly adresses port 278, it can not be redirected via the net use command.
Maybe your application can print to a file, like some older Autocad versions could, you could call this file lpt1 and it will be printed.
Maybe you could use NW3.11 exclusively for printing.

Share
There is a difference between file shareing in novell and NT, NT uses a proactice system to avoide simultanious writes to files, this meens if two clients try to OPEN (not write)a file for writeing the second client gets the share violation. Novell uses a postactive system, here many stations can open a file for write simultanious, but only one station can write to this file, if a second station tries to write then it will get the violation.
This is much closter to the thing that DOS is doing (DOS simply takes no care at all)
Maybe you could also use NW3.11 for this application.

An other solution could be the use of Microsoft Services for Netware (ca. 300$), here the NT-Server emulates a Novell 2.2 Server and you can use the original novell dos clients.


Best Regards
Michael

But here is a solution from MS
 
0

Featured Post

Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now