safe mode problem

I have recently reformat my PC. After i reinstalling win 98, i found that i cannot go into safe mode. it display a message
"HIMEM.SYS has detected unreliable XMS memory at 0250183A".XMS driver not installed". But i found himem.sys in the c:\window folder.
thgAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Patricia Siu-Lai HoCommented:
thg, make certain in the config.sys consists of these lines: -

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS

Let me know your outcome.    pslh
0
biardCommented:
what?  sounds like bad ram to me.  you don't even need a config.sys file or an autoexec.bat in win 98.  Mine are both empty an I can boot to safe mode all day.  Really, sound like bad ram to me, or a potential mbr virus.  Why did you format your drive?  Bad problems?  If so, try some different ram.
0
zombiwulfCommented:
During a Safe Mode boot, himem.sys is loaded with a command line switch of /testmem:on. This does a much more extensive ram test.

To verify that himem.sys is really reporting this, add the line "device=c:\windows\himem.sys /testmem:on" to your config.sys.

Reboot - you will probably get the same error.

If you want to get to Safe Mode in spite of what himem.sys is reporting, change the line in config.sys to device=c:\windows\himem.sys /testmem:off. Reboot and at the Startup menu choose the option for StepbyStep confirmation - Say No to the system registry and autoexec.bat and Yes to everything else except loading windows.

Type win /d:m to load windows in Safe mode.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

sorgieCommented:
I'm not sure if you have a RAM problem but baird is right about autoexe and config sys You don't need them for safe mode or windows to run. I would reinstall windows or run SFC (system file checker) see if a file is corupt or missing.
0
rayt333Commented:
This is a typical error of bad Ram, maybe it doesn't show up when it does the memory count, but all that does is count it.
Do you have other random errors?
Can you remove part and try going into "safe mode"
try different memory or take your and have it tested.
0
thgAuthor Commented:
to pslh:
  i found no problem after adding your suggestion in my config.sys.

to zombiwulf:
  i can run safemode after adding your code, what causing this? Any suggestion to pass through testmem:on?
0
Patricia Siu-Lai HoCommented:
thg, Here about the switch adding to the HIMEM.SYS.

/TESTMEM:ON|OFF
    Determines whether HIMEM performs a memory test when your
    computer starts. By default, HIMEM tests the reliability
    of your computer's extended memory each time your computer
    starts. This test can identify memory that is no longer
    reliable, and unreliable memory can cause system instability
    or loss of data. HIMEM's memory test is more thorough than
    the standard power-up memory test performed by most computers.
    To prevent HIMEM from performing the memory test, specify
    /TESTMEM:OFF. Disabling the memory test will shorten the
    startup process. The default setting is /TESTMEM:ON.

In Win98, there is already a line of HIMEM.SYS /TESTMEM:ON is loaded in the io.sys.
Therefore, even though you did not add it in the config.sys, this command is still working.

However, there are some softwares / programs which may need to read this line of HIMEM.SYS and EMM386.EXE in the config.sys in legacy or compatibility.

However, if you add HIMEM.SYS /TESTMEM:OFF in the config.sys, this line will over-ride the default settings of win98 in the io.sys and disabled the testing of memory.

If you would like to enable it again, just delete the switch in the config.sys as:
DEVICE=C:\WINDOWS\HIMEM.SYS

pslh
0
rayt333Commented:
I think if you check your memory you will find you have a bad chip, which is what biard said. When you bypass the memory check you can open in safe mode right?

Then test your memory!!
Take it to a store and ask them to check it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.