File Access in Corel Suite 7--Word Perfect

In the past, I have been able to access a Corel Word perfect file by double clicking its icon in a folder such as My Files. The double click opened both the application (Word Perfect) and also the file. Now, when I double click the file's icon, the application is opened, but the file is not. I have to click on File/Open and then find the file and click on it to get the file displayed. This condition is probably due to something I did in deleting and restoring some files (related to Netscape which I do not use) or to something my wife did in fooling around with options or preferences. In any case, I can't get back to the old way of simply double clicking on the file icon to get it on the screen.
Incidentally, double clicking still works fine for such things as Corel Quatro Pro, Word Pad, or Note Pad. It's only Word Perfect that seems to be giving the trouble.
rbkochAsked:
Who is Participating?
 
1cellConnect With a Mentor Commented:
OK, here's what's happening.

This is a problem with the spaces in the name.

The space in the name Dames Treas. Rept.wpd
is making Corel think that with each space you are adding an execution parameter.  Nice bug huh?  The funny thing is, only versions 6.1 and older have anything listed in their tech database for any problems relating to execution parameters.  However, this is listed as one of the problems.  You know, I love Corel everything because it is a strong competitor of Microsoft and they are great programs BUT this is crap.  Can't open files with either spaces or maybe just multiple spaces.  Regardless, at least you know and can correct the problem.  Aren't you glad though, that you didn't reinstall everything?


(.)
0
 
oldgreyguyCommented:
go to Windows Explorer, and do a search for *.BIF, you should find one file, delete it, reboot, and try again.  This file will be rebuilt when WP opens

bill
0
 
biardCommented:
It sounds like the file you are double clicking is corrupt or empty.  Perhaps when you go to open the file from within word perfect, you are going to a different location to a different copy of the file.  The reason the application is opening is that the file extinsion is associated with that application.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
rbkochAuthor Commented:
Great to have two of you working on my problem!
oldgreyguy,
I found one BIF file labelled wpcset.BIF. I deleted it and rebooted and then retried dbl. clicking on a Word Perfect icon. Same result as before. Got the application but the file didn;t show up. Incidentally, wpcset did NOT rebuild itself when I rebooted. It was still gone! I restored it from the recycle bin after the test failed. What next?

biard,
The problem occurs with ALL files that have a Word Perfect icon. I get the application(Word Perfect), but not the file. Any other ideas?

Bob
0
 
1cellCommented:
rbkock, are these .wpd files?  if so, you probably need to reassociate them through explorer.  

1)  Open Windows Explorer
2)  Click on View | Options and then file types
3)  Scroll down to .wpd files and highlight it
4)  Click edit
5)  In the edit file type window make sure under "actions" it says open.  If it does not, you will need to click "new" and create an action for "open".  If there is an action called open, hit the edit button.  Either way, in the action field it should say open and in the "Aplpication used to perfoorm action"  you should have the path to WordPerfect ( ie.  c:\progra~1\corel\wordperfect.exe)

0
 
biardCommented:
Not to contradict you 1cell, but that must be working or else, it wouldn't open wordperfect when he doubleclicks a document.
0
 
biardCommented:
Do the files have the extension .wpd ? or is it some other associated extension?  Either way, try this:  In Wordperfect, go to Tools | Settings , double click on the file icon , and uncheck "Use default file extension on open and save".
0
 
1cellCommented:
i would tend to agree but have seen this happen many, many times especially with Corel but more recently saw the exact same problem with Microsoft Word.  When you double clicked on the .doc file, it would open word but no file with it.  When I recreated the association, worked fine.
0
 
biardCommented:
Agreed.  I must add that I have not had the displeasure of working with Wordperfect in a very long time.  And I am very aware that their quality assurance/control measures used to leave a lot to be desired.  They are the only place (except Microsoft) with more bugs than my old bachelor pad. :)
0
 
biardCommented:
If none of this works, I'd say reinstallation of Wordperfect should do it.
0
 
1cellCommented:
agreed
0
 
AwmytieCommented:
Or upgrade to WP-8 or 2000?
0
 
biardCommented:
Any luck?
0
 
rbkochAuthor Commented:
To both 1cell and biard. Yes, they are all .wpd files.

To biard:  In WordPerfect|tools, there is no "settings" in the dropdown menu.

To 1cell: I tried your recommendation. The path to the .exe file looked a little weird, so I used browse to construct a new path which now reads:
C:\Corel\Office7\WPWin7\WPWin.exe.
Now, I still can't get my .wpd files by double clicking and I have a new and ugly development. When I double click on a .wpd file, I now get an error message which reads as follows:
"Cannot find the file (file path here)or one of its components. Make sure the path and filename and that all required libraries are available". Behind that message is the window containing the .wpd file I'm trying to bring up. When I close that window, there is a message behind it which says:
"WP Warning
The file "Rept.wpd", as specified in the execution parameters, cannot be opened"
Using the Windows "Find" function, I searched the entire hard drive, and sure enough, there is no "Rept.wpd"
file.
Reinstalling WordPerfect is not as easy as you make it sound. all of Corel came pre-installed on my machine (over 600MB of code) and I've never been able to make re-installing sub-applications work. Please don't leave me in mid-air.

0
 
rbkochAuthor Commented:
Adjusted points to 200
0
 
1cellCommented:
I would say that there's probably a problem with the association still.  Sorry for confusing things further.
0
 
rbkochAuthor Commented:
I am receiving multiple copies of an email with your URL and no new information when I bring up your website. Any idea what's going on?
0
 
1cellCommented:
you mean the URL for this page?
0
 
rbkochAuthor Commented:
Yes, your comment page.
0
 
1cellCommented:
you mean my personal info page???!!!

0
 
rbkochAuthor Commented:
No, I don't even know what your "Personal Info page" is. I'm talking about the page with all of the comment history on it.
0
 
1cellCommented:
ok, I thought you meant the page that you would get if you clicked on my name.  Is it still happening even when there hasn't been another comment added?
0
 
1cellCommented:
back to the issue:

try this

in explorer, find a whatever.wpd
hold down shift and right click it
select "open with"
in the "open with" dialogue, find word perfect
with the "always use to open files of this type" selected click OK
0
 
rbkochAuthor Commented:
Hi 1cell,
Glad to see your sticking with me. The deluge of email URL's has ceased. I think we may be making some progress - we're down to one error message, but still no file access by double clicking. I did what you said (actually, you have to left click. then hold down shift and right click) and set up the process of opening .wpd files with Word Perfect (always). Now, what I get when I double click a .wpd file is a message saying "WPWin Warning". "The file "Rept.wpd" as specified in the execution parameters, cannot be opened". It turns out that "Rept.wpd" is a contraction of the actual file name which is Dames Treas. Rept.wpd.
When I click on OK just below the error message, I get a blank Word Perfect page, ready to be worked on. If I go to File|Open, I can browse to the file I've been trying to open, double click it and it will come up on the screen.
Now, if we could figure out what the "execution parameters" are and how to fix them so "Rept.wpd could be opened, we'd have it made.
0
 
1cellCommented:
what this is going to be is parameters within WP or the open with line that enable WP to open specific file extensions and work within the Windows shell.  I believe what we're finding here is that WP has become corrupt or is missing files.  If it is truely impossible to reload it, you might be stuck.
0
 
1cellCommented:
by the way, I hope you didn't think I'd leave you hanging after causing so many errors with my previous posts.

LOL, I can only try again........
0
 
1cellCommented:
is rept.wpd a document you created?
0
 
1cellCommented:
ok, found a ton of info

Problem

 Starting WordPerfect gives the error "WPWIN Error: , as Specified in the Execution Parameters,
 Cannot be Opened." Then WordPerfect Starts.


Answer:

 Remove any environment variables which set the WordPerfect username to be the user's full name.


Details:

 In one instance, the network was running a Novell server with Windows 95 on the workstations. The  system login script was setting a WordPerfect environment variable to the user's full name. For  example: set wpc="/u-%FULL_NAME". The /u specifies the user name to WordPerfect. (This was
 probably left over from earlier versions of WordPerfect.)

 This is why the error happens: When WordPerfect is executed it adds any environment variables to  the end of the execution command. If the execution command is followed by a space and then a  filename, WordPerfect opens that file after it starts. For example, "c:\office\wpwin\wpwin.exe  mydoc.wpd" would start WordPerfect and then open the file named mydoc.wpd.

 In the above scenario the space between the first and last name made it so that the first name was  understood by WordPerfect to be the user name, and the last name was taken to be the name of a  file which WordPerfect was supposed to open after it started. Since no such file existed,
 WordPerfect returned the error.

 Note: A better way to set the environment variable would be to use the Login Name: set wpc="/u-%LOGIN_NAME". This environment variable is only necessary for WordPerfect versions
 5.x. WordPerfect 6.x and above hashes the user name to provide unique user files.

much more coming
0
 
biardCommented:
If none of this works, I'd say reinstallation of Wordperfect should do it.
0
 
rbkochAuthor Commented:
1cell,
Although I understand practically none of your dicussion of environment variables, a glimmer of light is dawning. As I recall, when I changed the path in Explorer|View|Options per your instructions, there was previously a path which ended up with something like "ddeex" following the .EXE command (there may have been additional letters beyond the length of the visible field). Would these have been environment or execution parameters? I anxiously await your next missive.

In response to your earlier query, Yes the file Rept.wpd was one created by my wife some time ago. Its full name was Dames Treas. Rept.wpd, and yes, there was a space between "Dames" and Treas." and also one between "Treas." and "Rept."

Bob
0
 
1cellCommented:
    OK, first off, don't give me too much credit.  The last post was a cut'n'paste from a Corel tech dbase.  Really, it's not the exact problem or even the version you have but it's what I was getting at before with the file association.  Unfortunately, it proves most likely that simply associating the wp.exe isn't enough.  
     Basically, what it IS saying is in a network environment, the variables provided by the network can interfere with Corel opening files correctly.  The same theory applies here because now, and I believe before, those command switches were changed.  We changed them after they didn't work but I think they were changed before that which caused it not to work before.
     What do we do now?  Well unless you posted this in the Win95 section in error, you don't have 98 and we can't simply restore a copy of the registry which would fix this easily unless you make backups of it regularly.  Do you???  If not, all we can really do is try to find the right switches.  Hehehe  I'll look for more info from Corel tomorrow.  
     ut for now, what changed right before this happened?
New software?  New ISP?  Was this document created on another computer?  Do you edit this document on any other computers?  Are any of the computers networked?  Did you try Cheerios for the first time the night before?  anything..............
0
 
rbkochAuthor Commented:
Unfortunately, I do not make copies of the registry, and I am not networked. Shortly before this problem started occuring, I deleted two copies of Netscape Navigator which had just been taking up space on my hard drive. I used a piece of software called "Remove-it 95" to remove these two copies of Navigator (and later, I restored them using the same software). I restored because I thought that might solve the problem we're trying to solve. It didn't. Currently, they are once again deleted. When I first deleted, "Remove-it 95" listed several files that would not be deleted - either because they were in use or because they were shared by another application (.dll files I believe). Is it possible that those files ended up in another folder so now they can't be found - and Corel is trying to find them?
I also deleted some files that were in a folder labelled QFNONL which appeared to be related to Netscape Navigator. I did not deleted any files directly related to Corel, nor any Windows System files.

Bob
0
 
1cellCommented:
rbkock, been doing some research on this and found some info.

instead of posting a ton of possibly useless info here, do something for me.  Create a .wpd document in wordperfect and save it to a different folder on the C:.  Now, close wordperfect and goto explorer.  Double click the new .wpd file.  What happens?
0
 
1cellCommented:
also, do a find files for SH_SH_.ENV file and WP_WP_.ENV.

let me know if you find them.
0
 
1cellCommented:
also, what version of Word Perfect Suite is this, I was assuming 8.0 but need to know for sure.
0
 
rbkochAuthor Commented:
1cell,
Just returned from an all day shopping trip. Sorry for the tardy response. I entered Word Perfect and set up a test file. I saved as OneCell (in your honor)directly in the C:\ folder. Then I closed Word Perfect, went to Explorer and double clicked on "OneCell". To my astonishment, Word Perfect came up followed by "OneCell". Should I try a longer file name with spaces, or do you have what you need for now?
The Word Perfect version is 7.0, not 8.0. The result of START|FIND was negative for both SH_SH_.ENV and WP_WP_.ENV. Neither of them could be found.
Bob
0
 
rbkochAuthor Commented:
1cell,
I did try the "Onecell" experiment with a different and larger file name. This time it was "The Big Test" (without the quotes). This time the file would not open. It begins to look as though only file names acceptable to DOS can be opened in this way.
Bob
0
 
1cellCommented:
not a problem with name size, problem with spaces in the name.
0
 
rbkochAuthor Commented:
1cell,

I'm about to accept your answer, and I did test a long (continuous) file name even before I read your most recent response. I'm sure you're right. But that leaves unanswered the question of why this problem cropped up when it did. I've been able to double click and thereby open Word Perfect files with spaces in their names for a couple of
years. Do you have any idea why this suddenly became a problem? I'll be interested in your response.
Bob
PS: I'm about to start renaming all existing Word Perfect files to get rid of the spaces.
B.
0
 
1cellCommented:
hmmm.... it DID work before......

I guess, all I can guess as far as that goes is, as we were talking before, something probably changed this somehow.  Be it added software, Corel itself, or whatever, something had to change it as far as the environment goes.  

To be totally honest, I find it suprising that they were able to be pulled up before.  The fact is, the file name is added to the execution line.  Spaces in the execution line indicate a switch.

ie:
where the program is c:\progra~1\corel\suite7\wp.exe is the wordperfect executable:

when you double click the file, it would run
c:\progra~1\corel\suite7\wp.exe Dames Treas. Rept.wpd

each space indicates a switch.


Out of curiosity, I wonder what would happen if you removed the periods.  Could be causing the problem also.

Bottom line and my recommendationis this.

STOP USING LONG FILE NAMES!!!!

Not only do they give programs fits but they also take up more space on the drive.  This is because, and I recall this loosely but  for each file with a long file name, the name has to be recreated in 8.3 format so it can be accessed in programs which do not use long file names.  Not a huge issue but worth keeping the file names down to 8.3.
0
 
1cellCommented:
thanks, rbkoch

glad I could help out and learn something myself.
0
All Courses

From novice to tech pro — start learning today.