How to telnet Linux

I'm using Win NT to connect to Linux.
I would like to know how to telnet Linux in Win NT.
Ping between these two machines is successful, but no response
to telnet.

Many thanks!
andersyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tromadorCommented:
Either you haven't found the telnet application in Windows NT, or you haven't got your telnet daemon running correctly.

You don't say if you can telnet from other platforms successfully.

If it's an NT problem, the simple answer is to use the start button, then choose "run" and simply type telnet into the box. That should get you going.

If you can't telnet from other platforms as well, then you may have a misconfigured telnet daemon.

Ensure lines in /etc/services like this..

telnet          23/tcp
telnet          23/udp

And a line in /etc/inetd.conf like this..

telnet  stream  tcp     nowait  root    /usr/sbin/tcpd  in.telnetd

Then send a HUP signal to inetd to restart it..

#kill -HUP <inetd's PID>

If that still doesn't allow a telnet, then I need more information about the problem. Is it just NT that can't get a connection? What have you tried to fix it?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
v_likicCommented:
Check if you have the file /usr/sbin/in.telnetd
If not, the telnet server is not installed on your linux
machine. The server RPM should be in the RPMS directory
on your distribution CD, named something like
]'telnet-server-0.12-10mdk.i586.rpm'

To install the telnet server, as root do
# rpm -ivh telnet-server-0.12-10mdk.i586.rpm

which should create the file /usr/sbin/in.telnetd, and then
you should be able to telnet to your linux box.



0
andersyAuthor Commented:
It works!

Thanks, tromador and v likic.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.