Quake 3 on a G3

My G3 was shipped wit a ATI Rage 128 Graphic-Card PCI (bought Sept. 99) but Quake 3 does not run! Why? It does run a G4 which seems to have the same ATI-Card.
Who is Participating?
KevSpencerConnect With a Mentor Commented:
Hi, itz_me.

The Power Mac G4 uses a digital version of the ATI Rage 128 card. It's slightly different than the b/w G3 version. However, Quake 3 should run fine on your G3. You are likely missing the appropriate OpenGL and the InputSprocket extensions, which are required for Quake to run (I found this out yesterday).

On the Quake 3 CD, there are likely an installer for the OpenGL software. If not, you can also download the OpenGL software from Apple's Software Updates web site. (http://asu.info.apple.com/)

The InputSprocket software is included with the Mac OS. I know you're using at least Mac OS 8.5, which is the minimum version that a b/w G3 can run. Be sure that the software is active in the Extensions Manager control panel.

Then, of course, verify that your G3 has the minimum necessary system requirements needed to run Quake III.

Gib hearty!
itz_meAuthor Commented:
Hi Kev.

the latest OpenGL Driver (1.1.2) is already installed and the InputSprocket is active in my Extensions Folder. But Q3 always crashes when I try to start it up. There is one thing I found out yesterday: the Demo of Unreal Tournament gives me the information, that my Graphic-Card does not support Open GL, but RAVE for Macintosh. Do you know sthg about such differences between ATI128-Cards?

Waiting for solutions, itz_me.

Quake requires OpenGL to run, which could explain the crashes. Do you have other games that work properly, such as Tomb Raider 1/2/3, Future Cop, or Unreal (you mentioned Unreal Tournament--that worked only in RAVE mode, you said?)?

OK. Check these settings as well.

--How much RAM do you have? Is it sufficient to run Quake 3 according to the game's requirements?
--Is Virtual Memory on? It can't be for this game, in all likelihood.
--Reduce the resolution to 640x480 and colors to Thousands for now.
--Turn off ALL extensions and control panels except Apple CD/DVD, the InputSprockets, the ATI drivers, Memory, Monitors & Sound, and QuickTime.

I may have more thoughts here, so I'll drop a line later about this.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.