Flicker in MS Visual C++ 6.0

I'm running Windows 2000 5.00.2072 and using Visual C++ 6.0. Just lately I've noticed that the Visual C++ UI seems to "flicker": the mouse changes from a pointer to a hourglass for an instant at about 1 second intervals, and the list of files in the project seems to be redrawn at the same time. I've tried stopping all other processes that I could stop with no effect, and only MSDEV seems to be using any CPU time. This only happens during the code editing phase, and only with one workspace, which is a COM object. So I'm pretty sure that the problem is in Visual Studio. Any ideas on what could be causing this annoying behavior?
LVL 1
webbAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tdubroffCommented:
Not sure if this helps but:

> SYMPTOMS
> When editing source code or a dialog resource with the Visual
> C++ version 6.0 source or resource editors, the user may
> experience a slowdown in performance. The resource editor
> shows a noticeable delay when tabbing between controls. In
> the source editor, the cursor seems to hesitate when passing
> through function definitions when using the arrow keys. In
> both instances the CPU usage is near or at 100%.
> CAUSE
> The Visual C++ IDE makes a large number of file accesses to
> the ClassWizard information file (Projectname.clw).
> RESOLUTION
> Invoke ClassWizard to regenerate the ClassWizard information
> file, then dismiss the ClassWizard dialog by clicking OK or Cancel.
> STATUS
> Microsoft has confirmed this to be a bug in the Microsoft
> products listed at the beginning of this article.
> MORE INFORMATION
> This performance problem arises under very unique
> circumstances. Projects that exhibit the symptoms described
> above contain a large number of dialog resources, typically
> 200 or more. A test project which included 130 dialog
> resources was used in writing this article. Two additional
> events must occur for the symptoms to show themselves.

> First, associate a dialog resource to a new class using ClassWizard.

> Then, do either of the following:

> * Invoke the WizardBar (this happens automatically when
>   navigating code or resources).
>   
> * On the Tools menu, click Customize, (dismiss the dialog box
>   by clicking OK or Cancel).
>   
> NOTE: The order of events is not important. If the WizardBar
> has been invoked and then dismissed, the WizardBar engine
> will continue to run in the background. To disable the
> engine, close and restart Developer Studio after closing the
> WizardBar. To dismiss the WizardBar do the following:

> Click on empty space in the Developer Studio window.

> Clear the WizardBar item in the toolbar list.

> Q170511 </support/kb/articles/Q170/5/11.ASP> WizardBar
> Notification Slows Down Dialog Editor
> Each subsequent association of a dialog resource to a new
> class will require this resolution to be repeated.
> Additional query words: kbDSupport
> Keywords          : kbwizard kbEditor kbide kbResourceEd
> kbVC600bug kbDevStudio kbClassWizard kbGrpDSTools
> Version           : winnt:6.0
> Platform          : winnt
> Issue type        : kbbug

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
webbAuthor Commented:
I think it is related to the ClassWizard because when I go to class view it says it has all these files to load, but they never get loaded. But it is not the problem above. I tried building the .clw file with no effect.

When I close the workspace window the problem goes away, so it is definitely related to MSDEV and its file list.
webbAuthor Commented:
Huh, deleting the .clw file I created following tdubroff's comment fixed the problem. So I'll give tdubroff credit for putting me on the right track.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C++

From novice to tech pro — start learning today.