Home Network problems

I've got two computers networked together over ethernet. In order to get them to see each other, I use a static IP for each, plus a gateway of course. One is Win 98, the other Corel Linux (Debian). I've got my Corel setup where I can use the network to browse through it just fine. But I need to dial in to access the Internet. I set up my kppp dialer before the network, and it worked fine. Now that I have configured the network, kppp connects to my ISP, but I can't browse the web. How do I get web access without a SOCKS_NS error or Netscape stalling out looking for a way on to the NET?
CoachBHBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

biardCommented:
What is your default gateway device set to on the Linux machine?  If it is eth0, change it to ppp0 (or whatever your ppp interface is identified as).  And the default gateway ip of both machines should be the internal ip address of the Linux box.
0
CoachBHBAuthor Commented:
I I understand you right, I need to make the gateway IP address the same as the static IP address of my Linux machine. However...how do I go about in changing the default gateway on my Linux machine?
0
biardCommented:
Edit the /etc/sysconfig/network file.  Change GATEWAY=xxx.xxx.xxx.xxx to your ip address.  Also change GATEWAYDEV=eth0 to ppp0.  Also, make sure FORWARD_IPV4=yes, NETWORKING=yes, the host name is correct (name of your machine + domain), and domain name is correct.
0
dcavanaughCommented:
I'm not sure he needs GATEWAY=xxx.xxx.xxx.xxx in /etc/sysconfig/network, especially when you consider the fact that the IP address for ppp0 is almost certainly dynamically assigned via the ISP.  I would try 0.0.0.0  Aside from that, I agree with biard.
0
NickCommented:
I had exactly the same problems yesterday (7th Jan), and being a newbie to Linux this might not be the correct answer, but it resolved the 'Netsacape $SOCKS_NS' error for me.
I sussed out that Netscape (and any other internet app that required names resolution) was looking at my local machine for a Name Server.  It isn't of course.  So after much head scratching I then added in Linuxconf Networking>Name server spec (DNS)... the default domain, and the 2 IP's of my ISP's DNS servers.  E.G.
default domain:- myisp.com
nameserver1:1 xxx.xxx.xxx.xxx
nameserver2: xxx.xxx.xxx.xxx
All worked fine!
If you don't know the IP addresses of your ISP's DNS, you will have to contact them for the information.

Hope this helps!

Nick
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.