Home Network problems

CoachBHB
CoachBHB used Ask the Experts™
on
I've got two computers networked together over ethernet. In order to get them to see each other, I use a static IP for each, plus a gateway of course. One is Win 98, the other Corel Linux (Debian). I've got my Corel setup where I can use the network to browse through it just fine. But I need to dial in to access the Internet. I set up my kppp dialer before the network, and it worked fine. Now that I have configured the network, kppp connects to my ISP, but I can't browse the web. How do I get web access without a SOCKS_NS error or Netscape stalling out looking for a way on to the NET?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
What is your default gateway device set to on the Linux machine?  If it is eth0, change it to ppp0 (or whatever your ppp interface is identified as).  And the default gateway ip of both machines should be the internal ip address of the Linux box.

Author

Commented:
I I understand you right, I need to make the gateway IP address the same as the static IP address of my Linux machine. However...how do I go about in changing the default gateway on my Linux machine?

Commented:
Edit the /etc/sysconfig/network file.  Change GATEWAY=xxx.xxx.xxx.xxx to your ip address.  Also change GATEWAYDEV=eth0 to ppp0.  Also, make sure FORWARD_IPV4=yes, NETWORKING=yes, the host name is correct (name of your machine + domain), and domain name is correct.
I'm not sure he needs GATEWAY=xxx.xxx.xxx.xxx in /etc/sysconfig/network, especially when you consider the fact that the IP address for ppp0 is almost certainly dynamically assigned via the ISP.  I would try 0.0.0.0  Aside from that, I agree with biard.
Commented:
I had exactly the same problems yesterday (7th Jan), and being a newbie to Linux this might not be the correct answer, but it resolved the 'Netsacape $SOCKS_NS' error for me.
I sussed out that Netscape (and any other internet app that required names resolution) was looking at my local machine for a Name Server.  It isn't of course.  So after much head scratching I then added in Linuxconf Networking>Name server spec (DNS)... the default domain, and the 2 IP's of my ISP's DNS servers.  E.G.
default domain:- myisp.com
nameserver1:1 xxx.xxx.xxx.xxx
nameserver2: xxx.xxx.xxx.xxx
All worked fine!
If you don't know the IP addresses of your ISP's DNS, you will have to contact them for the information.

Hope this helps!

Nick

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial