• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 418
  • Last Modified:

Modem drops connection under heavy load

I am using debian linux and connecting to a service provider using pppd  I'm using the persist option, if it matters.  Anyway, under heavy load, such as a file transfer or listening to real audio, the connection will drop.  Otherwise it lasts indefinitely.  I can connect to another provider without any difficulty but they purposefully disconnect me every 2 hours that elapse.  I've tried lots of modem connect strings, as well as fiddleing with the pppd options files.  Nothing seems to help.
0
namida
Asked:
namida
  • 10
  • 5
  • 5
  • +1
1 Solution
 
namidaAuthor Commented:
Adjusted points to 80
0
 
ibishopCommented:
Have you checked your current system load via the "top" command when this problem occurs?

I have seen, when the system is under VERY heavy processor load (I'm talking about 95%+ sustained processor usage and large amounts of swap memory in use) PPP connections time out and die for no other reason than the system timed itself out on the link.  This is more of a problem with modem connections than most others, because the system itself is performing the function of router, whereas with bigger links you tend to have a dedicated router with it's own CPU and memory - thereby minimising the problem.

Perhaps a few details of the system you're running this on may assist myself and others to offer more advice.  In addition, if you could perhaps tell us what the processor utilization is like when you're using realaudio etc., it would also be good.
0
 
namidaAuthor Commented:
Okay, the system is a cheapie old 486 (Which seems to have weathered Y2K quite well I might add).  I'm kind of linux stupid, so bear with me.  I'm using Linux for it's IP masqurading ability, mostly.  As such, I'm running realaudio on a windows 98 pc in the same room connected via ethernet cable and a hub.  I have several other computers of varrying types connected as well.  The CPU load on the linux machiene indicates it's over 90% idle, and using real audio seems to have no real effect on it, since it is running on a different PC, I wouldn't have expected it to.  The modem is a US Robotics Sportster 56K.  The ethernet card is a 3com Etherlink XL.  Is it perhaps possable I have an IRQ confilict?
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
bughead1Commented:
I suspect your ISP doesn't recognize this sort of network traffic as "activity." You may need some sort of "keepalive" function.

Try this in a terminal window or at the command line:

ping -i 30 xxx.xxxx.xxxx &

where 30 is the interval between pings (you may need to adjust that)  and xxx.xx... is your ISP's IP address.

When you are done, enter: killall ping

This is a very common problem. An ocassional ping will keep the connection alive, even when things stall.

For more info, see man ping.

Just don't use ping -f.  That floods the server you are pinging and might land you in court.  If you ping every 30 seconds or so, nobody should care in the least.
0
 
ibishopCommented:
I certainly wouldn't imagine an IRQ conflict is to blame for this - otherwise nothing would work.

The suggestion of pinging the remote server (A ping every 30 seconds or so to the "remote ip" you see when you connect isn't a bad thing - because that's almost like a "keep-alive" packet - and only travels between your machine, and the terminal server at your ISP.  I generally do this with the command :

ping -i 30 -s 8 x.x.x.x >> /pinglog.txt

when I'm debugging a connection - because you can often see, about the time you get disconnected, a huge rise in the latency on the ping (anything above 10,000ms is going to probably cause you to disconnect - and many things can cause this effect) - and logging this - looking for a pattern - can tell you a lot.  Otherwise just omit the ">> /pinglog.txt" and watch it in the console.
0
 
namidaAuthor Commented:
I've tried pinging, and looking for a reason, any reason, for the disconnect, but see none.  The ping reports a delay of about 2,500 ms almost constantly, a lot of them a smidge quicker (about 2,000) and some very quick (Less than 500).  All this while i'm playing a real audio file from the net.  If I am not, then the ping times are about 200-500.  When the connection drops, there is no warning of any kind, it just quits.  Ping times do not seem any higher.  I can maintain my connection forever, so long as I do not do anything that uses up a great deal of my bandwidth such as downloading a file or using real-audio (Which is really just downloading a file anyway).  It works fine on another provider, as well as for my room mate who may download anything he chooses.  I've tried using his account with the same results, and have used an alternate provider with no trouble at all (Except for the hostile 2 hour disconnect).  It's not me...  And it's not them...  It's me AND them togeather, somehow.
0
 
namidaAuthor Commented:
Adjusted points to 100
0
 
patowicCommented:
This could very well be line noise issues.  What sort of connect speeds are you seeing with the modem?  Especially at rates > 33.6, the connection can be very much at the whim of the line it is using.  

Of course, the USR modems are usually very, very good--so they'll have less problems with line noise than other modems.
0
 
namidaAuthor Commented:
I've thought of that and tried forceing a connection at a slower speed.  (33.6, actually)  It had no effect.  Also i've used the init strings to keep the modem speaker on, to listen and see (hear) what the problem was.  The modem sounds perfectly constant until disconnect where it emits a solid tone for a fraction of a second.  I don't know what that could mean, but I don't think it's line noise...
0
 
patowicCommented:
Is this an internal or external modem?
0
 
namidaAuthor Commented:
Internal, though I try to use ifconfig to see if it's transmitting, and it seems to be.  Just isn't recieving anything in responce.
0
 
patowicCommented:
how odd.  I'm afraid I have no idea :(
0
 
ibishopCommented:
I'm assuming you currently have your port speed locked in as 115,200 in your initializations.  

Pulling this number back to 57,600 or 38,400 on a trial basis will isolate whether your modem is overflowing on the high-bandwidth activities, and timing itself out.

While this theoretically loses some potential performance, it is unlikely to affect the throughput on an audio/video stream as the data is already compressed.

It is well worth trying - you'd be amazed how often just the drop back to 57,600 stabilised a previously unstable connection.
0
 
namidaAuthor Commented:
I did as you suggested and pulled the speed back, but I had to pull it waaaay back.  I'm still testing it as we speak, but dropping it to 38400 significantly increased connect duration.  I'm now testing with 19.2 Kbps instead, and so far so good.  The PC is a DX4 80, which means that the bus speed is likely only 20 Mhz, could this be the cause of the alleged "overflow" or is there some other problem contributing to it?  Would switching to a faster system perhaps allow me to raise the serial port rate again?
0
 
patowicCommented:
It could be that you do not have a 16550A UART--meaning that your serial ports are essentially unable to handle bit rates > 38.4 kbps.

Installing a serial port card may fix this problem.  Upgrading to a newer motherboard almost certainly would...
0
 
ibishopCommented:
I would tend to second patowic's view.  The pulling back of the speed is a VERY good way of determining if the port isn't up to the job, and either a new serial card or M/B upgrade might be the way to go

Good Luck :)
0
 
namidaAuthor Commented:
It's an internal modem, though, and the UART is built right in.  I know it's a 16550A, as it says in my modem manual.  And the higher setting works with another provider...
0
 
patowicCommented:
hrm.  This is an odd one...  Perhaps you have significant line noise when connecting to the 'slow' provider.  Did the higher setting work to the 'slow' provider with a different OS?  Or have you only had linux on this machine?
0
 
namidaAuthor Commented:
This machiene has only used linux, I'm afraid.  I don't think it's line noise because I've listened to the modem speaker up until I lose the connection, I know what it sounds like when it loses because of noise, and this isn't it.  Everything sounds perfectly normal but for a fraction of a second.  The link seems to be terminated intentionally for one reason or another.  Since I'm online now, though, I believe I'm going to have to accept the answer from ibishop.  It does work, albiet poorly.
0
 
namidaAuthor Commented:
This solution works, but I had to tone it down much more than suggested before the connection became stable (19 some odd k).  I suspect additional problems somewhere.
0
 
ibishopCommented:
Was just wondering if you have asked your ISP to see what is happening at their end - their terminal server may well have something in it's logs that can assist with the diagnosis, and if they're good folks, they probably won't mind taking a look for you.
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

  • 10
  • 5
  • 5
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now