problem with NE2000 ISA PNP

Hi,
 
  I am trying to set up my NE2000 ISA PNP and encountered some problems. I obtained the latest kernal 2.3.8, configured it to support NE2000 ISA, to have loadable modules support. But after I built the kernel, there was no network modules generated except for the dummy.o. (I have done 'make modules' and 'make modules_install'). And my network card is not detected during the boot.
 
 A related question is: I know my NIC's io address is 0x220, but how do I tell linux to use this address?

  Any help is greatly appreciated!

wyldsj
wyldsjAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
Uhm, not to be rude, but if you not know these basics, why do you use a development kernel? 2.3.x is development, 2.2.x is stable kernel.

Anyway, boot do DOS (with a dos floppy if nessesary) use the setup util for the card to disable PnP, and hardcode it to 300/10. then the ne2000 mod will automatically pick it up.
0
wyldsjAuthor Commented:
Thanks j2, for your information. However, the situation is a bit changed now and I hope you don't mind if I ask you the following question. I've doubled the points :)

I have used expert mode to do the setup again, and there I got my chance to input the IO address and the Interrupt of the NIC. And yes, the setup program detected my NE2000 and the installation proceeded smoothly. During the boot of the system, it printed message like "bringing up interface eth0   OK". So I assume my network card has been successfully identified. When I got into the system, I did a 'ifconfig', I see two entries, one is eth0, the other is lo. I thought there should be no problem any more. But alas, when i do a 'ping 192.168.0.3' (which is a computer in my LAN), it tells me network unreachable. When I do a 'ftp 192.168.0.3', it tells me 'no route to host'. When I do a 'ls /dev/eth0', it shows me nothing! I don't understand that why there is no device eth0 created while the boot says interface eth0 was brought up successfully?

By the way, when I do a 'ftp 192.168.0.1' (which is my own IP address), it is successful.

Thanks again for your help.

wyldsj
0
j2Commented:
net devices are NOT present in /dev/ so that is normal.

'ftp 192.168.0.1' does NOT use the nic, but uses the software loopback, ro that doesnt mean anything.

could you give me the output of "route -n" please?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

GrahnCommented:
try this:
modprobe ne2k-pci io=0x220
or
modprobe ne io=0x220

worked for me...
0
wyldsjAuthor Commented:
sorry j2, for the long time delay.

Here is the output of route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.1     0.0.0.0         255.255.255.255 UH    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo


0
wyldsjAuthor Commented:
sorry j2. I have to open the question again because I still didn't get your reply...
0
maxchowCommented:
wyldsi,

Try to type this command in:

route add default 192.168.0.1

Regards

Max
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.