Automatic Poweroff in Windows 2000

I have Windows 2000 RC3 Server.  For some reason when I shutdown the computer it won't automatically poweroff.  I had Win2k RC2 before and it powered off automatically everytime.  Now whenever I do it, it just sits on a screen that says now safe to turn off comp.  I know my motherboard is compliant.  I have an ABIT BH6.  I have already tried going to the registry and changing this to "1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"PowerdownAfterShutdown"="1"

Any help would be greatly appreciated.
html4Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Typhoon121597Commented:
I have the same problem with BE6 and BE6-II mb's, also the powerswitch there is not working.
It works on some installations, I have currentley a srv 2195 that powers off fine.
0
j2Commented:
ABIT Bx6 is flawed, ACPI doesnt work properly. There is (according to uusenet) a BIOS upgrade for the ABIT, and you must have ACPI set up properly.

And for typhoon. RTM, keep the powerbutton pressed for 4-15 seconds (depends on bios rev) and it will power off. If that doesnt work, "doubleclick" on the powerbutton.
0
html4Author Commented:
I have a Abit BH6 motherboard and if it is the ACPI, then why did it work in RC2??
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

j2Commented:
with my "bx6" i meant : "ANY B-something-6-boards"

I dont know why, but my co-worker had the same problem with his BH6. But upgrading BIOS and installing RC3 again solved it.
0
zzconsumerCommented:
I had the same problem with my Abit BX6 2.0. Go to control panel and activate either
ACPI or advanced power management, depending on the board and settings you have.
0
DjamonCommented:
I believe this issue is being addressed in the final releases of Win2k.
0
html4Author Commented:
zzconsumer,

Could you be specific on exactly what to do.  TIA.
0
BackBonECommented:
I've both BE-6 and BH-6 both running NT5 Build 2195 with no shutdown problems. Here's what I've done:
* Check your BIOS settings for ACPI & APM Settings
* Got to Control Panel/Power Options
Go to APM tab and be sure "Enable Advanced Power Management support" is checked.
if these both are setup correctly you shouldn't have any problems with soft shutdown nore with hard.
0
html4Author Commented:
Hey BackBonE,

Whenever I go to Control Pannel and Power Options, I don't have an APM tab, I only have power scheme, advanced, hibernate, and UPS.  Nowhere do I see the Enable Advanced...  Could you please clairify where I should go to get this done.

Thanks

0
BackBonECommented:
There you go:
Start/Settings/Control Panel/Power Options
There should be four tabs like:
Power Schemes, Advanced, APM, UPS. Go to APM tab there should be a check box saying:"Enable Advanced Power Management support." -Check it and "Apply".
If there is no such tab please check your BIOS, it could report to W2K that it is not APM compatible.
By the way the build I'm talking about is 2195. There also should be rgistry key to enable APM, I'll search for it, if you'll still have problems.
0
tnordhoffCommented:
In addition to BackBonE's solution, you might also try a BIOS update: http://www.abit.com.tw

I'm not sure if you did something wrong by setting the PowerDownAfterShutdown value. My system switches off, but the key's value is 0.

Might be you have to run a hardware detection after your BIOS update to make the system recognize you have APM.
0
faroutCommented:
sorry but the server ver of w2k does not!! do auto power off
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
html4Author Commented:
Thanks farout, i recently found that out too.  Is there any other way to do it or something i could do?
0
TaomynCommented:
Sorry guys, but Windows 2k Server Final Build DOES support power-off !!!

My Gigabyte GA-5AX powers off a treat !!!!!
0
html4Author Commented:
Taomyn,

Could u please tell me how to get my computer to do that.  Your would be greatly appreciated.

TIA
0
TaomynCommented:
First check the processor type in Device Manager. If it mentions ACPI then you're ok - check the BIOS and make sure the other power management settings are enabled. If not then you'll have to trash Win 2k and start again. The nice people at Micro$oft won't let you change the processor type if the power-management is incorrect (please anyone tell me if I'm wrong - I nearly trashed my system when I tried to force the change, so my workstation is stuck until I decide to start again).

If you have to reinstall, take no chances and make sure the Win 2k setup installs the correct HAL. You do this by pressing "F5" at the prompt where you are asked to press "F6". Pick the appropriate ACPI enabled processor type.

Things should go as normal from this point on and your system should power down properly.
0
BackBonECommented:
Dear html4,
I've tested W2K Server on Gigabyte ga5ax, soyo 133 & 155, Abit be6 & be6 II. All do have an apm option all support ATX via ACPI, all do soft shutdown through OS. Tested processor are PII, Celeron and PIII. Check Taomyn's comment.
For Taomyn I'll check to your issue when next terminals arrive.
0
TaomynCommented:
BackBonE: according to other sources, the reason you can't change between ACPI HALs is because the registry entry trees are fundamentally different, and can only be generated at setup time (or something like that anyway).

An extract from Microsofts bulletin Q234558 states:
NOTE: You can use this procedure only to upgrade from a single-processor HAL to a multiple-processor HAL. If you use this procedure to change from a standard HAL to an ACPI HAL (for example, after a BIOS upgrade) or vice-versa, unexpected results may occur, including an inability to boot the computer. For information about troubleshooting Windows 2000 HAL issues, please click the article number below to view the article in the Microsoft Knowledge Base

I know the above to be true when I tried to go from non-ACPI to ACPI and I had to use the Remote Console to copy back the previous HAL files.

At least upgrading from single CPU to multi CPU is far easier than with NT 4. I could never get uptomp.exe to work and always did it manually (scarey stuff).
0
vocsCommented:
Here is what you need to do:
Enter the following system environment variable with a value of 1: devmgr_show_nonpresent_devices
Close computer properties and reopen. In hardware manager click the option "show hidden devices" and see if you can find "NT APM Legacy Support" with a red X on it. Simply activate it and it will shut down on its own again :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.