• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 287
  • Last Modified:

Linksys Ethernet 10/100 Lan card

Hello to everyone,

This is Jason.  I think that I have narrowed the problem down to a simpler question.

Fact 1)  When Linux loads "Delaying eth0 allways fails.

Fact 2)  When I go through NETCFG and activate and save changes to the interface, the command line shows, "Delaying eth intialization.

Fact 3)  Even though I just activated and saved the settings, when I check back with NETCFG it is set as inactive.  In other words, it will not remain activated.

Maybe this will help narrow the problem.

Any Ideas from anyone??


Jason
0
browerjason
Asked:
browerjason
  • 10
  • 5
1 Solution
 
lewisgCommented:
Sure sounds like the network card is:

1. dead
2. not configured
3. incorrect ethernet module loaded

Since "Delaying eth0" means that eth0 has failed to start.

So:

1. Using the Linksys config program that came with the card verify that the card works and run diagnostics (If the card passes this you may rule out 1&2 above). Make a note of all any io/irq/memory settings.

2. Check your distribution documentation and see what module needs to be loaded for the Linksys card. It may be de4x5. In your /etc/conf.modules (Red Hat) there should be a line that goes something like this:
alias   eth0    de4x5
Of course if the module you need is not de4x5 it would be something else at the end.

3. Run ifconfig. At the bottom of the eth0 section any io/irq/memory settings that appear must agree with the values that you noted from the LinkSys config program.

Hope this helps. I you still have problems please post the following:

1. linux version/distribution
2. exact network card name, chipset and configuration
3. results of ifconfig

later...
0
 
browerjasonAuthor Commented:
Thanks, I will work on that for a while and post back later.

Jason
0
 
browerjasonAuthor Commented:
Question?  The diagnostics is a dos program.  I tried to double click the diag.exe file on the Windows box, but it would not let me execute the program.  I am new to Linux and know little commands or tricks.  What do I do since dos is not currently on my computer?


Jason
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
browerjasonAuthor Commented:
OK, I booted up to the Windows 98 disk and then put the diagnostics disk in the drive and ran the program.  

The register test passed

The loopback test passed

The Ping test asked me to "Enter one of DOMAIN, WORKGROUP or Name."  I left what was in the box because I did not know what to put??  The default was DOMAIN.  It failed the test.  I then ran it again and typed in the Linux machines IP address but it failed to.  What do I do?

I am running Linux Mandrake based on Redhat 6.0.  The Network card is a Linksys LNE100TX verion 2.0 Ethernet 10/100 LAN card.  The machine is a compact 75mhz Compaq Prolinea with a 13.6 gig hardrive and 82 meg ram.  There is also the possiblity that this computers bios does not support this card since it has a system requirment of 90mhz.  The sales support told me that It should work though?

Results of ifconfig:

lo     Link encap: Local Loopback
       intet addr: 127.0.0.1  Mask:255.0.0.0
       UP LOOPBACK RUNNING MTU:3924 Metric:1
       RX packets:450 errors:0 dropped:0 overruns:0 carrier:0
       collisions:0 txquelen:0

Here is a link to all of the technical info about the card.  

http://www.linksys.com/pdf/family/fam_LNE100TX.pdf


Jason
0
 
lewisgCommented:
I assume the "ping" test was in the Linksys diagnostics. Usually unless you have another computer on the network running the same diagnostics software the "ping" type tests won't work. Did all the other tests work?

From the results of ifconfig the netcard is not installed. You would see a section like the lo section that is labled eth0.

What to do?

1. work on section 2 of the proposed answer. You may want to try the following. Using the Linksys diagnostic set the card as follows
PNP - disabled
IRQ - 5
I/O - 300
speed - 10Mbs
Be SURE you are loading the correct module with any needed options!

2. Get a 3c509 ISA network card for troubleshooting. It will save you a lot of grief. You should be able to find one for under $15 on eBay or a used computer store.

good luck!
0
 
browerjasonAuthor Commented:
Well, I belive that I have tried most everything imaginable to get this booger working.

The last comments were greatly appreciated.  I though for sure that this would be the solution.  Though I could not specify IRQ 5 because it was allready asigned to sound.  I used three instead.  Still could not start the modem.

I even exchanged the card for the only thing left available.  It is a D-Link DE-220P.  I can not get the software to compile per a long set of instructions that I got from d-link.

What about this 3c509 ISA card.  I see it is specificly listed as a card in the installation Window.  Maybe buying one of these and reinstalling would be the answer?????????????????????????



Take it easy



Jason
0
 
browerjasonAuthor Commented:
In the last comment, Ignore "MODEM" I meant network card.  Also Ignore all grammar and spelling errors.  It is 12:24 Central time and I have been up untill 3-4:00 am the last week trying to get Linux setup and the Network installed!

Jason
0
 
lewisgCommented:
IRQ 3 is assigned to com2 so if you want to use IRQ 3 be sure that you have no com2 (check CMOS setup).

You may want to pull the sound card until you get networking working...
0
 
browerjasonAuthor Commented:
By the way, I tried the NE 2000 compatible selection on setup, but it could not find the card

J
0
 
browerjasonAuthor Commented:
I can't belive it.  After all this time I have been struggling, I think it may work.

I removed the sound card and set the d-link card to IRQ=5, IO=300 and reinstalled Linux Mandrake.  For the first time in about 18 install attemps, it probed for the Network card and found it.  I set my IP address to 192.168.1.1, but I don't know what I should put for the DOMAIN NAME, HOST NAME, SECONDARY NAMESERVER, TERTIARY NAMESERVER, and any other menu that may come after this one.

I will wait to finish this install until after I get an answer.  I don't want to screw it up after all this work

Things to know:

     My primary goal is to hook this computer up to my small network so that I can access Linux from my other computer.
     I would like to have both computers connected to AT&T's @HOME service that I currently have on my Windows Box.  But, there is an extra fee to get another IP address.  Is there a way around this so that the windows computer can share a connection with the Linux computer?

     I realize that I will actually have the info for the DOMAIN, HOST NAME.......if this can be rigged through the @HOME service.  But, I still need this info so that I can finish the install assuming that only one computer will have a @HOME connection.

Thanks


I'll be awaiting the usual excellent advise



Jason

0
 
browerjasonAuthor Commented:
Well, I called Best Buy and they told me that the domain name does not matter.  I listed my domain as linuxserver and host as linuxserver.

In the smb.conf file, I set my workgroup as @HOME,  encrypted passwords as yes and under the shares section I uncommented Browsable and saved the file.  I stopped and re-started samba then restarted Windows, but I still can not see the Linux computer in my Network Nieghborhood on the Windows box?

Though, when I do an IFCONFIG the eth0 card now shows and remains active!!!!!!

Thanks Lewisg!


Now what should I do to get the Linux box to show on the Windows??  I'm lossed at this point?


Jason
0
 
lewisgCommented:
Browse the linux samba server:
Most likely the reason is that samba is in workgroup @HOME and the windows machine is in workgroup WORKGROUP. I would set both the machines to WORKGROUP.

Internet sharing w/ 1 IP:
The easiest and most secure way is with NAT/firewall box.

Go to www.sharethenet.com and look at their product. You can either pay the money or roll it yourself. Either way the download version allows a 30 minute connection before it has to be rebooted - long enough to troubleshoot.

Install the software on a old 486 box w/8megRAM,2 NIC's and a floppy and hook it between the ADSL box and your hub.

You could do the NAT stuff in your linux box with 2 network cards - 1 to the @home service and the other to your windows machine.
0
 
browerjasonAuthor Commented:
I set both the samba server to WORKGROUP, restarted the server, and restarted Windows.  Still, no Samba?


Thanks

Jason
0
 
lewisgCommented:
Here are some good Samba resources:
http://us1.samba.org/samba/docs/DIAGNOSIS.html
http://www.oreilly.com/catalog/samba/chapter/book/index.html
http://www.linuxdoc.org/HOWTO/SMB-HOWTO.html

Also at a DOS prompt type NET and see all the cool stuff you can do...

Several possibilities for the no browse:

1. Microsoft client not installed
2. Microsoft client not bound to TCP/IP
3. No browse master
4. No SMB usernames matching windows usernames
5. Network problems - can the machines ping each other?
6. No vaild shares in smb.conf
7. ...

It is time to close this question...
0
 
browerjasonAuthor Commented:
Well, I will accept your excellent suggestions, but it still won't work.  I can not ping each others address?
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 10
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now