exe file extention recovery

Hello all.
My problem is i accidently deleted my file association for the *.exe and most of my files will not run. the open with box comes up and anything i select just brings me back to the open with box. i tried the shell.inf install and was going to try the tweakui file but i can't get it to open. Can someone please HELP!!

Thanks!!
lopezrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LermitteCommented:
Use scanreg.exe /fix

Mario
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
calacucciaCommented:
Hi Lopezr,

I'd suggest to try a fix via the registry editor:

Go to Windows directory and find regedit.exe, run it

My Computer\HKEY_CLASSES_ROOT\.exe

In the .exe registry, you should have:

(Standard)      "exefile"
Content Type    "application/x-msdownload"

Now try to run some and see what help it does.

Good Luck,

Calacuccia
0
joedCommented:
If he deleted the EXE association Regedit.exe probably won't run.
0
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

calacucciaCommented:
Well joed, probably not. Maybe it will, as he states that 'most of his files' don't run. I simply did not think about the obvious problems he could have.

Hopefully something brought up here will work,

Calacuccia

 

0
lopezrAuthor Commented:
i tried everything everyone suggested and to a point some things worked. I still get errors for the applications.  I can't remove/edit the file association for applications. Can someone tell me how to do this. I'm positive this is the problem.
after i did the regedit that calacuccia recommended my regedit doesn't work in windows.

i appreciate all the help.
0
lopezrAuthor Commented:
i renamed my system.dat and user.dat files, restarted windows and i got back the use of regedit, but no luck with the anything else.
in file types box for application
type:                   application
content type:        application/x-msdownload
default extension:  dll
actions:

should there be something in actions??
0
lopezrAuthor Commented:
PROBLEM SOLVED.  
I USED THE SCANREG /RESTORE command in ms-dos and selected a file with a date prior to my days of trouble, everything was back up and running.

I would like to thank you all for your help.
0
rayt333Commented:
You should accept the comment made by Lermitte
Date: Sunday, January 09 2000 - 08:52AM EST  as the answer since in all fairness this is what he suggested and you said it worked, right???
0
adam8Commented:
Could someone just send you a registry file that you run and it writes information to the registry
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.