Kernel build errors

Just been compiling new kernel in Redhat 6
Current kernel 2.2.5
Trying 2.3.29, mainly for the USB development stuff.

I've followed the normal procedure for compiling new kernels & get through the config ok.
then when i go to "make dep" I get the following error:

         gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o scripts/mkdep scripts/mkdep.c
         scripts/mkdep.c:23: ctype.h: No such file or directory
         scripts/mkdep.c:24: stdio.h: No such file or directory
         scripts/mkdep.c:25: stdlib.h: No such file or directory
         scripts/mkdep.c:26: string.h: No such file or directory
         scripts/mkdep.c:27: unistd.h: No such file or directory
         scripts/mkdep.c:29: sys/fcntl.h: No such file or directory
         scripts/mkdep.c:30: sys/mman.h: No such file or directory
         scripts/mkdep.c:31: sys/stat.h: No such file or directory
         scripts/mkdep.c:32: sys/types.h: No such file or directory
         make: *** [scripts/mkdep] Error 1

Funny part is, these files do exist in the path that it is looking for.  The script actually points there!  All the symlinks etc are ok, have checked all that.
And yes, I do have the latest versions of required packages :o)
Any ideas??
TIA

(this is the first time I've compiled a new kernel on this installation of RH 6.  Previously I was running RH 5.2 & compiled at least 3 kernels with good success)
freemo20Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

freesourceCommented:
By required packages, do you mean the latest glibc-devel package?
0
freemo20Author Commented:
just an update on this one, i d/l 2.3.37 to see if it would make any diff. but no, same error on make dep

i have d/l & installed the glibc-2.1.2-11
thats the one needed by kernel 2.3.37, but not the devel package of same.  Will try that & let u know.

Thanks
0
freemo20Author Commented:
Worked perfectly after installing glibc-devel.
Thanks again.
(can now see my USB modem, so will have some fun tonight trying to get it to work.  Bring on kernel 2.4, so i can make Linux my primary OS!)
0
freesourceCommented:
I asked freemo20 this question in relation to his question:

By required packages, do you mean the latest glibc-devel package?
 
The problem was solved.   Basically, what happened was that glibc was updated, but glibc-devel wasn't.
glibc-devel has the standard header files and object
files  needed for creating executables, so although the header and object files were still present from the old glibc-devel, the new gcc didn't recognize them because they were in an older format.

Your welcome, and I am glad the problem is resolved.  Have fun!

You can grade my answer now, so I can get my points, and eventually a T-Shirt!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.