• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 310
  • Last Modified:

Can't install printer on NT Workstation

We have a Windows NT 4 server providing shares to several printers on our NT network. I am able to install a driver on Win 95 clients to print to these shares with no problem. The usual procedure to do this on a Win NT Workstaion client is to logon to the client (not the network) as administrator. In the Add Printer wizard I just type the path of the printer (\\server\printername) and the printer is then available to all who logon to the network on that client. Starting a few days ago, when I type in the path I get an error message "Could not connect to the printer. Access denied." Since I have administrator rights in NT this seems odd. I don't have an access problem otherwise. If I browse the list of servers, no printers show up. If I double-click the server for these printers I get the hourglass for a few seconds and nothing happens. If I use Network Neighborhood to browse to the server, when I double-click it I am asked for username and password. If I supply the appropriate credentials I see and can install the printers but if I do it this way they do not appear on the client when other users log on the the network from that client machine.
0
donander
Asked:
donander
1 Solution
 
vdmjorisCommented:
In NT only local printers are for all the users.
Network printers are profile-bound in NT. I dont know of a way to add them as an "all users" device. You do NOT need admin-rights to connect to a network printer so they can easily be mapped through the login script or every user can make the mapping for him/herself.
The "access denied" error message does not have to mean it is a access rights problem either, if it doesnt find the printer you can just as well get that error message (however: that depends on your network situation).

In other words: let a 'normal' user log on (ON THE NETWORK !!!), have him/her type the path to the printer -or browse to it -  and see if that works.
0
 
morguiCommented:
Logon to the WinNT Workstation as Domain Administrator (not local administrator) and then add the printer.
(It's supposed all these machines are in the same domain)

You can't see the printers and the system asks you for username and password when browse through Network Neighbourhood because you're not domain administrator. So logon as domain administrator and add the printer as you did before.

Hope this will help you.

Morgui
0
 
donanderAuthor Commented:
Neither of these suggestions works. See my explanation below.

To morgui: The NT Workstation administrator account name (for administering the local machine) is fixed as "administrator." Only this account can log on to the local machine. We do have a domain administrator account/password and I tried logging on to the local machine with this but the machine will not allow this account to logon to the local machine.

To vdmjoris: Until about 1 week ago I was able to log on to the local machine as administrator and add a printer as long as I knew the UNC to it so I could type it into the Add Printer wizard. If I did it that way the printer was available to all users who logged on to the network on that PC.

I should add something that may be pertinent. All these printers are in fact in our domain within our organization, but our domain is a resource domain. When we log on to the network we log on to the master account domain for our organization. There is a one-way trust between the two domains (our domain trusts the master account domain.) Our NT Workstation PCs (those in our resource domain) used to me members of the master account domain but about two months ago we were required to remove them from the master account domain and make them members of our resource domain. After we did this everything worked fine. I only provide this info for completeness in case it may have any bearing on the problem.

Thanks,
donander
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
spreemanCommented:
This might be worth a try. Log onto the machine as local administrator and set your own (network, not administrator) profile to have administrative rights on the machine, then log in as yourself. You will be able to add the printer and also have access to the network path. I find that on the machines at my workplace, logging on simply as 'administrator' of the local machine doesn't let me connect to any printers.
0
 
donanderAuthor Commented:
I already tried this. If a user has administrative rights on the local machine it doesn't make the printers they create available to others, only the administrator account seems to have this affect. Giving users who log on to the network administrative rights DOES allow them to install software and make certain changes to the system configuration.
0
 
spreemanCommented:
Are you sure your TCP/IP on that machine is working properly? You might be able to 'see' the other computers on the network because of other protocols installed on them, but the printers may only be set up as TCP/IP, so you can neither see nor add them. I have also had an instance where a software installation on the server knocked out the list of printers, and a quick reinstallation of Jet Direct on the server (if that is what you are using) resolved the problem.
0
 
frankaCommented:
On the NT server with the printer shares (LPR Ports) you provide the access rights. so if everyone is allowed to "print", you can logon as domain user on the workstation -> new printer -> network printer and select the printer you want. then the client loads the print drivers from the server although you are noch logged on as an Admin. This network printer is only bound to the user who installed the remote printer.
0
 
TooKoolKrisCommented:
What you need to do is make sure that the permissions on the shares are set to full controll if people outside of the Administrators are going to be setting up printers on their Pc's. NT only allows Local and Domain Admins. as well as workstation admins to have these rights. If you want your users to be able to do this themselves then add them to the local admin group on their pc. and give everbody full controll to the printer share until they have connected the printers to their pc's. After all connections have been made then you can drop the share permissions down to print for everybody and take those folks back out of the local admin group. This can all be done from a remote location at your desk if you have the admin toolz or on the server itself.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now