Linksys Ether16 ISA card install problem

I am trying to get a Linksys Ether16 ISA card to install using Redhat 6.1 expert install.  I have disabled PnP and set the card to 300/10.  I have run the Linksys diagnostics and the card passes just fine.  The card is supposed to be NE2000 compatible.  When I try to load the NE2000 (ne.o) driver during install (specifying the I/O and IRQ info), I get the message "device or resource busy".  I have tried other IRQs (5,11) with the same result.  I have powered down between each try.  Any suggestions would be appreciated.
jmaisselAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dcavanaughCommented:
make sure you are doing a depmod -a   somewhere in your startup.

in /etc/conf.modules, you should have lines like this:
alias eth0 ne
options ne IRQ=10 IO=0x300

If that doesn't work, describe the new situation.  Post the results of the ifconfig and dmesg commands.
0
biardCommented:
Also, check your BIOS.  You should go to the resource configuration page and select the IRQ you have the Network card set to currently.  Change it from "Auto" to "Legacy ISA".  You may have to change it to accept manual entries first, before it will display a list of irq's.  Usually this is found under Plug and Play BIOS options or something along those lines.
0
dcavanaughCommented:
Oops... lowercase on "io" and "irq".  I'm not sure, but it probably matters.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

sumawuschaCommented:
Also make sure that no other adapter (eg video)
uses this resources. (cat /proc/ioports, interrupts).
Dis you compile kernel module and ne2000
support into your kernel?
0
KROMCommented:
had exactly the same problem...

use a bootable ms-dos-floppy-disk to
boot to ms-dos and then open the networkcard-configuration utility that should have come with your card.
use it to change the basic adress to
f.e. 260h

interrupt 5 used to work fine.

when you changed it, boot linux and
run the configuration-tool.
(f.e. Yast)
change your network-card basic adress
to 0x260 or whatever you´ve choosen above.

that, hopefully, will work fine :)
good luck!

[KROM]
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmaisselAuthor Commented:
KROM rules!!

It worked perfectly.  This was a thoroughly frustrating problem for me.  Thanks a million (or 75, as it were).  

I could not have done this without the experts exchange.  KROM, did you figure this out by trial and error?  Did you look at the proc file system?  

Thanks again!  8^)
0
KROMCommented:
happy i could help :)

this problem took me a long time to solve too...
i´ve tried a lot of configs but the
network card was always "busy"

finally i got the answer
here at experts-exchange, too.
nobody else had any idea :)

good luck with your further actions :)

[KROM]
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.