Jet database cannot open.... exclusive....

I'm trying to open a database, I copied it to a disk brought it to work, it's not running NT forgot if it's 98 or 95, using Access 97 and try to run database and I get this error.

-------------------------------------
The Microsoft Jet database engine cannot open the file It is already opened exclusively by another user or you need permission to view its data
-------------------------------------

I tried looking it up at support.microsoft.com but didn't get far.
LVL 2
fredmastroAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ZWhizCommented:
That message looks like the one that comes up when you try to open a database using the wrong version of Access.  It may have a workgroup file associated with it (System.mdw) that requires you to log in when you start Access, and that gives you permission to convert the old database file to the current version.
0
BrianWrenCommented:
First I would try unchekcing the 'Exclusive' box in the open dialog.

If that doesn't work, I would try repairing the database--make a backup first!

It might also be that the database is protected, and that you do not have permission for any of its objects...

You could try saving your copy of the .MDW file, and then replacing it with a copy of the one from work.  I don't know very much about .mdw files, but I know that they can be a requirement in some cases.

Brian
0
clanglCommented:
This has to do with the System.mdw file that Access97 uses for its security.  First look at where you computer at home is referenceing the .mdw  file. This can be done with Regedit [Local MAchine, Software,Microsoft,Office,Acces,8.0,Jet,SytemDb]. THis will tell you where the file is.  Then check the security on the database itself(Groups, Users). See if  you did anything out of the ordinary.
At work use Regedit again and see where the System.mdw is. Same way as you did at home. Then Mock the Security at work.

Hope this works
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

JimMorganCommented:
clangl:  Welcome to EE.

Thanks for your answer but in this topic area we don't mark a response as an answer.  Because you are new, I'm cutting you some slack.  This time. :-)

You might not be aware of it but EE allows a member who posts a question to accept any comment as the answer to that question.  It makes it so much easier since that feature was installed.

The question is left in the open forum longer which provides the asker more options to solve his/her problem.

The asker can choose which solution he/she feels best understands and solves the problem.

There is no embarassment on either side when the asker 'rejects' an answer at not being what they were looking for.

About the only time that we mark a comment as an 'answer' is when directed to do so by the asker or the answer we gave is so obvious and we know absolutely that there is no better answer.  Even then we are reluctant to do so and none of us are omnipotent.

Enjoy being on EE.

Jim
0
JimMorganCommented:
Fredmastro:  Not knowing which of the two possible errors are causing the problem, you need to test some things out.

If you wrote the DB at home and brought it into work, then you should know how it was setup.  

Were you using anything other than the defualt System.MDW at home?  (If you didn't specifically join a workgroup, you were using the default MDW and that is not the problem.)

If you were using a MDW, then you need to copy it along with the DB as well.  Then join that workgroup on the system at work.

Is the disk file valid?  Can you open the copy from the disk at home?  If not, you have a bad disk or copy.  Access/Jet has no way of knowing.  They look for certain headers and if there is garbage where they should be, you will get a message like that.

If the work version of Access is 2000, then you will not get that message.  If it is an older version, you will get a message that it can not recognize the version of Access.

Opening the DB in exclusive mode has not bearing on anything other than if the DB were already opened once and you tried to open it again, it would complain.  There is not a chance that you were opening more than one copy of the DB at the same time?

The final thing is permissions.  Permissions are built into the DB and have nothing to do with the MDW other than the DB would be looking to the MDW to see who has the rights to open the DB.  If you have turned off rights to ADMIN and were opening the DB with the default MDW, then you would be trying to open it as ADMIN and there you go.

Let us know what you have done to verify the various scenarios and then we can go from there.

Jim

0
Cyber_BeberCommented:
This is a database corruption.
There is more then one solution:

First:

1. Create a new database.
2. In the new database, choose Get    
External Data -> Import.
3. Choose all object and Import.
4. You have a new copy of your database.

Second:

Use a Microsoft Application called JetComp.exe. Make a search in Microsoft.com and you'll find it. It uses Jet, but stronger then a usual Compact/Repair.

Third:

If non of the above worked - give up.



0
JimMorganCommented:
clangl:

Now that we have the next version of EE running, there is a new option which allows you to change your answer to a comment.  Will you please do that?  It will reopen the question for more response and everyone will feel more comfortable.

Thanks

Jim
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.