Movie stops to load sound???

My movie stops to load sound at different occasions when new sound is introduced,  how can I buffer all the sounds while displaying a message "Wait" and then movie plays on smoothly after all buffering has taken place.
fmuftiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

simonokCommented:
Have you tried changing the sync to stream. This should buffer the sound if its a long sample.

ss
0
SuperMarioCommented:
Create a scene with only ONE FRAME in it. Have an animation symbol playing in that frame saying "Wait" or something. Go to that Frame's actions. Now put in the following Action Script (by using the plus button in the Action tab)

If Frame Is Loaded(Scene 1, 200)
  Go To and Play(Scene 1, 1)
End Frame Loaded

Replace Scene 1 with the main movie's scene name. Replace 200 with the amount of frames your main scene has in it.

This will actually download *ALL* content before delivering the movie.

Hope this helps!
-Dan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Flash

From novice to tech pro — start learning today.