.htaccess in cgi-bin

i have a .htaccess file in my
htdocs/protected dir and it works fine
(i am asked for a password from the
.htpasswd file when i request the
data in that dir via my browser)
but when i put the exact same .htaccess file into my cgi-bin/protected dir it
wont work!

any ideas why not?
paulwhelanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

feenixCommented:
You probably don't have the appropriate settings in your web server configuration. By default the system probably doesn't allow you to set the auth config for the CGI directory.

If you have Apache, check that there is a line like:
AllowOverride AuthConfig
in the config of your CGI directory.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.