Connect to NT network for Internet Access

Thank you in advance for any help you can offer!
I now have two computers running at my desk at work.
The first one is a Pentium II running Windows NT4.0 which frequently locks up and is otherwise generally bothersome.
The other computer is a Pentium180 with 64mb RAM and 6.4G drive running LinuxMandrake 6.0, my question is:

How do I connect to the NT server machine that offers internet access.  My Network Administrator has assigned static IPs to all 80 machines on the existing network and has also assigned an IP to my linux box as well.  When I ran the Linux installation, it probed the PCI NIC and found a Digital 21040 Tulip card.  I can ping myself but no other machine on the network.  No other machine can ping me.
When I run "ifconfig", I get the following information:
ethO  Link encap: Ethernet HWaddr 00:80::c6:f9:2f:a9
      inet addr:  192.187.224.81  Bcast 192.187.224.255
      Mask 255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 METRIC:1
      Rx Packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:100
      interrupt: 10  Base address:0xfc00

lo    Link encap: Local loopback
      inet addr: 127.0.0.1 Mask 255.0.0.0
      UP LOOPBACK RUNNING MTU:3924 METRIC:1
      Rx Packets 69 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0

My network settings are:
IP for my linux box:192.187.224.81
my machine's name: penguin.fluoresco.com
Domain: fluoresco.com  
NT server name/IP:  fluoresco.com  192.187.224.230
Gateway server: 192.187.224.254
Subnet mask:255.255.255.0

Under "linuxconf", my default gateway is shown correct.
Under "ifconfig", my Bcast is 192.187.224.255, should these be the same?

I am a little lost here since my Network Administrator also is running a Linux box (Redhat 6.0) and he can access the internet and also see the network shares.  I checked his network settings and compared them to mine, and everything that I could see was the same (except, of course, IP of my machine).  Do I need to set up SAMBA?  When I did the installation, I checked "EVERYTHING" for components, so I should have what I need to fix this issue.

Again, thanks for the help.  I have tried to check any HOW-TOs and read up as much as possible before I posted this question.
gregchavezAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

patowicCommented:
what kernel version do you have?  (uname -a).  Have you checked the cabling on your linux box?

broadcast and gateway addresses look good.

Also, specifically, what brand of NIC are you using?  (and chipset, if possible--sometimes the autoprobing doesn't work).

Do an 'lsmod'--is the tulip module installed?
0
gregchavezAuthor Commented:
patowic,
My kernel is 2.2.9-19mdk
Yes I checked my cables, I even switched the cables between the NT box which was a known good cable.

Since the time I originally submitted for help, I installed a new network card and re-installed the OS.  I still have the same problem.  My new card is TRENDnet TE-PCIW PCI Ethernet Card that is compatible with NetWare DOSODI NE2000
card, also is IEEE 802.3 standard compatible, I don't know the chipset.  I did a "lsmod" and the Ne2k-PCI module is shown with 1 user and a "autoclean" remark.
I did notice that when I use "linuxconf" under Network | Nameserver specifications, the "default domain" is blank.
Is this a problem?  It does show the server IP under "nameserver1" and "fluoresco.com" under "search domain 1"

Thanks again
0
patowicCommented:
default domain shouldn't matter.
I've actually avoided linuxconf up until now ;)

You are still unable to ping?

what does /sbin/route show?

I think this is a routing problem...

perhaps something like 'route add gw default eth0' (as root) will solve your problem?
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

patowicCommented:
oops...that was more terse than it needed to be :)

Good work on checking the cables!  Most people NEVER remember to think of that ;)  Swapping out the NIC was very logical as well...
0
tdyllCommented:
Did you notice on your ifconfig that you have no TX packets? That is important. It looks like you tried to ping yourself and the lo address reported the the error.

I have seen different distributions handle different network cards better than others. Why don't you try Red Hat or check the HCL for Mandrake. That way you could use a compatable card.
0
3408Commented:
First of all I'm not a Linux genius but a know something about networking. If anything I say seems totally incorrect then you should just disregard it.

If you ask me the loopback didn't produce an error. When you try to ping (or whatever) to yourself, an internal loop is done. This means that no actual data has been transmitted.

What disturbs me is that your eth0 can transmit (look at txqueuelen:100), but it isn't able to recieve.
When you ask me this means that your
1. Linux doesn't like your NIC      or
2. you haven't installed your NIC correctly.

The truth is that I had a similar problem with a Dlink DE-528CT. I had to add
   alias eth0 ne
   options eth0 io=0xff40 irq=11
to my /etc/conf.modules. Maybe you should try the same. It would look something like:
   alias eth0 tulip
   options eth0 io=0x???? irq=??
(of course fill in the ?)


Thanks for listening,
3408
0
dcavanaughCommented:
I find it interesting that ifconfig shows "Rx packets: 0".  This counter should increase because of SMB broadcast packets if nothing else, even if your routing was a problem.

I suggest the following:

Boot from a DOS floppy and run the configuration utility for your Ethernet card.  Disable Plug-and-Pray.   Take note of the IRQ and IO address.   Shut down the system and turn the power off.  Boot Linux and verify that the IRQ and IO address match what you see in ifconfig.  If it does, then you should not have to bother with /etc/conf.modules. If you need to, use 3408's comment to force the IRQ and base IO address.

Check your BIOS to be sure the IRQ you are using  has not been accidently allocated to the "Legacy/ISA" bus instead of PCI.

I do not trust linuxconf.  Please post the results of "/sbin/route -n"   I hope to see (among other things) a line that looks something like this:

Dest      Gateway               Genmask              Iface
0.0.0.0   192.187.224.254  0.0.0.0                eth0
192.187.224.81 0.0.0.0     255.255.255.255 eth0
192.187.224.0 0.0.0.0       255.255.255.0     eth0

I see you swapped cables with the NT box.  How about plugging the LInux box into the hub or switch port normally used by the NT machine?  A bad hub/switch port is one of the many things that might cause your current situation.
0
gregchavezAuthor Commented:
Thanks for the help everyone!
Here is the latest update:  
A. I already switched to a known working hub/switch port. Same problem.  
B. My Network Administrator had RedHat 6.0.  I am curious if this distribution will have the same problem.  If so, I will keep plugging through this with the suggestions you guys have offered.

Reloading RedHat now...will see what happens and post results.  Bye for now.
Thanks
0
gregchavezAuthor Commented:
Well Redhat 6.0 has the same problem.  But I did find out that I do not like GNOME, way too slow.  I reinstalled my Mandrake distribution and am back to square one.

3408, I tried adding the "options....." with no noticable change.  Thanks anyway.

dcavanaugh, here is the result of "/svin/route -n"

Destination     Gateway    Genmask            Iface
192.087.224.81  0.0.0.0   255.255.255.255       eth0
192.187.224.0   0.0.0.0   255.255.255.0         eth0
127.0.0.0       0.0.0.0   255.0.0.0              lo
0.0.0.0     192.187.224.254  0.0.0.0            etho

I will go ahead and disable the PNP in the card in DOS.
By the way, this is what my /etc/conf.modules file is:

alias etho ne2k-pci (remember, I changed cards earlier)
alias parport_lowlevel parport_pc
pre-install pcmia_core /etc/rc.d/init.d/pcmia start

Also, I am not sure how to check my BIOS to view settings of
"Legacy/ISA" bus.  I know how to access my BIOS, but what from there?  Thanks.
0
3408Commented:
I'm still convinced that it is nothing more than an installation flaw. Does Linux set the I/O and IRQ correctly?
0
lewisgCommented:
Linux is apparently unable to use PCI network cards on your machine. The fact that there are no TX Packets when you run ifconfig indicates linux is a problem transmiting on eth0. Since there are no RX Packets it appears that receiving dosn't look so good either!

My standing recomendation is to ditch PCI network cards at the first sign of trouble and install a ISA 10Mbs card for troubleshooting. My favorite is the 3c509 which is cheap on eBay or at you local used computer store.

0
3408Commented:
Lewisqs answer:
"Let's do it the windows way: If it doesn't work right away, ditch and buy something else." At least using windows you UPgrade, not DOWNgrade.

Anyway I've been searching the web a little bit and I think this will interest you:
http://cesdis.gsfc.nasa.gov/linux/drivers/tulip.html
0
lewisgCommented:
Hey 3408!

My answer is geared to TROUBLESHOOTING the problem. Don't be hanging any windows lover tags on me!

If the DEC chipset and PCI are such wonderful items why do most all the network card problems on this site involve them?

My method has always been to get the thing up and running then install the fancy stuff. Beating your head against the wall is no fun compared to continued sucess.

BTW - great driver site you found, I added the higher level directory to my list!
0
dcavanaughCommented:
I suggest you bounce lewisq's answer.  You don't need advise to swap cards and hope for better results.  ISA cards are not necessarily easer to install, nor are PCI cards the only source of frustration.

Now back to the real problem.  You can check the IRQ assignments in BIOS on a menu that is probably called "PCI Configuration", "Bus configuration" or something like that.  If IRQ assignment is "Auto", you're probably OK.  If you set it to manual, you can determine which IRQs are ISA and which are PCI.  

Can you post the results of cat /proc/interrupts and dmesg?  Did  you verify IO and IRQ while you were in the DOS setup utility?
0
3408Commented:
Lewisq:
Avoiding problems is the windows way; I know this because this is what I do every day (I'm an NT consultant). I don't like doing this but as you said "it's getting it up and running". So if this makes me a "windows lover" then I'm sorry, I can't help it.
The reason I like Linux is because problems do get fixed. My humble opinion is that not helping, if you're capable, is a betrayal to the linux community.
I understand the way you get things done, because I do it the same way. So, if I offended you that much then I apologize.

3408

not much to do around here, we need more info
0
3408Commented:
Lewisq:
Avoiding problems is the windows way; I know this because this is what I do every day (I'm an NT consultant). I don't like doing this but as you said "it's getting it up and running". So if this makes me a "windows lover" then I'm sorry, I can't help it.
The reason I like Linux is because problems do get fixed. My humble opinion is that not helping, if you're capable, is a betrayal to the linux community.
I understand the way you get things done, because I do it the same way. So, if I offended you that much then I apologize.

3408

not much to do around here, we need more info
0
gregchavezAuthor Commented:
Sorry 'lewisg', I want to try to get this working with the hardware that I have.  However, I have not ruled out getting an ISA card since that is exactly what I did to solve my phone modem problem at home.

Also, I am very grateful to all the help and troubleshooting tips and would like to know if there is a way to split up points and award to multiple parties?  Maybe I will just have to pick the the person who's answer is closest to solving the actual problem, (when I figure out what it is).

decavenaugh,
I did not get a chance to disable the PNP of the card in the DOS utility since my Network Administrator has taken the NE2000 card back (he needed it for another workstation).
So I am back to the "tulip" card.  I looked at "ifconfig" and noticed that the last line reads:
interrupt: 10  Base address:0xfc00
Does this mean that my IRQ is 10 and address is ????
When I had the NE2000 card in, the IRQ was 15 and address was 80.

Results of dmesg :  eth0: transmit timedout, status e4260000, CSR12 000050 cc, resetting.....
(repeated several times)

Results of cat /proc/interrupts:
0   552782  XT-PIC TIMER
1     165   XT-PIC KEYBOARD
2      0    XT-PIC  CASCADE
8      2    XT-PIC   RTC
10     5    XT-PIC   ETH0
12   14118  XT-PIC  PS/2 MOUSE
13     1    XT-PIC   FPO
14   59090  XT-PIC   IDE0
15     4    XT-PIC   IDE1
NMI:   0

I am going to walk away from this now and re-visit this on Monday, maybe some time away will help refresh my patience with this machine.  Thanks everyone, and I'll check back on Monday.


0
dcavanaughCommented:
If ifconfig says "interrupt: 10  Base address:0xfc00", then Linux thinks your IRQ is 10 (decimal) and 0xfc00 (hex).  So you need to be sure that IRQ 10 and IO 0xfc00 are really being used by your card, and not by anything else.  

If your card is really a DEC tulip and you need the DOS setup program, take a look at http://www.networks.digital.com/dr/nics/drivers 

Is this a combo card?  If so, you need the DOS utility to force the media selection to UTP (not thinwire/BNC or  AUI).  I don't remember auto-select as a common problem with DEC cards, but I always dictate the media type and my stuff works.

Is the card otherwise misconfigured?  I wonder if you might have full duplex enabled without the appropriate LAN hardware to support it.  When in doubt, go half duplex.  Same thing with fast ethernet (I'm not even sure 100mbps is possible with tulip cards).  

Your /etc/conf.modules file should be like this:

alias eth0 tulip
options tulip io=0xfc00 irq=10

Please post the output of lspci -v  and cat /proc/ioports /proc/interrupts

If you are sure the IO and IRQ are accurate, and Linux agrees with the card, and the PCI bus actually has that interrupt available, the card is sensed and you get the message at boot time, ifconfig sees the card and shows the right address, that's about as far as it goes in Linux.  Now we proceed to hardware settings on the card, and the cables and hub port you are attached to.  

When you posted the results of route -n, the first line was
Destination     Gateway    Genmask            Iface
192.087.224.81  0.0.0.0   255.255.255.255       eth0

It really says 192.187.224.81, right?

Have no fear, Penguin Power trounces Bill every time!
0
lewisgCommented:
I wonder about the IO address you are getting fc00 = 64512, seems kind of high...

As for the IO 80 on the NE2000 card I think that is usually a DMA thing.
0
ahoffmannCommented:
sounds like a cableing or media converter problem, see dcavanaugh 's comment above about UTP, BNC, AUI
0
patowicCommented:
Mandrake manages to break so much stuff in their standard distributions that you may be advised to recompile kernel and modules from clean source, such as that in kernel-2.2.14, available from http://www.us.kernel.org/
0
gregchavezAuthor Commented:
OK, I had some time to try a couple of things:
decavanaugh.... I tried the command "lspci -v" did not run.
Time to try something new!
Have a hammer and an old ISA card, choose hammer....wait!...choose ISA card.  Remove PCI card, install
ISA card.  Re-partition drive to have DOS partition, install DOS 6.1 and Linux.  Boot to DOS, run Utility/Setup (dowloaded setup utilities from Linksys Web Site)  Ether 16 LAN Card.  IRQ is set to 10 with address as 300.  Boot to linux, still no conectivity!   Read up on Linksys web site, it says I need to disable PNP through the Setup program in DOS.  The Setup program (in DOS) did not have an option for disabling the PNP but I could force write IRQ 3 and address 340 to the EPROM, did that.  Reboot to Linux, error loading module eth0 [failed].  Run "ifconfig", no eth0 report at all, just lo stuff.  Edited /etc/config.modules to show IRQ 3 and address to 0x340. Run "ifconfig" again,
etho
RX packets 0 (across the board)
TX packets (I now have some!)14 dropped
txqueuelen:100

lo
RX packets 61 errors, (rest are 0)
TX packets 61 errors, (rest are 0)


"lsmod" shows the ne module, OK
"ifconfig" now shows irq 3 address 340, OK
"/sbin/route -n" shows same as before (yes, dcavanaugh, 192.187.224.81, sorry about the typo last time)
I did verify my card settings in Dos to be:
IRQ=3
address 340
UTP connector

So, is the new lines in "ifconfig" a step in the right direction?  Maybe it is time to recompile a newer kernel?
I never have successfully done that before, any hints?
There are many options when recompiling the kernel, any way to keep the existing settings and just change what you need?

Unless anyone has an idea, it might be time to "punt" on this one, what do you think?  Please advise.  Thanks.
0
patowicCommented:
At this point, I'd be tempted to punt.
FWIW, I've had good luck with Netgear FA310TX NICs--not a bad one yet (I've got 8 running at home--5 constantly, another 3 on and off).  the 2.2.x series of kernels seems to like them quite well when using the included tulip code...

Good luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
themCommented:
With the tulip card in please dump the following data and post it:

cat /proc/interrupts
cat /proc/modules
cat /proc/pci | grep Ethernet
cat /etc/sysconfig/network
cat /etc/sysconfig/network-scripts/ifcfg-eth0

This data should help id the problem.
0
3408Commented:
Gregchavez:
--
I don't think that rebuilding a kernel is necessary to solve your problem. But if you want to rebuild it, I would use xconfig (in X, of course). Just start an xterm, go to /usr/sr/linux and type make xconfig. It gives you a nice form. Anyway you should read some info when want to rebuild. Actually rebuilding is simple: kick out what you don't need and keep the rest. One more thing; although you have an pci NE, you must activate the isa NE because it is actually the same driver (it's written in Ethernet-HOWTO) somewhere.

Lewisg
--
Sorry about mispelling your name (three times)


3408
0
gregchavezAuthor Commented:
OK, here's the story.  Thank you to everyone (in advance), but I solved the problem.  Apparently, there is some kind of problem with our 12 port hub in my building.  I could not even ping out of DOS using the Utility software that came with my ISA card!  Even when I unplug the network cable from my working NT box and try it.  I picked up my Linux box, carried it across the street to our main building, hooked up the cables my Network Administrator has on his diagnostic table, and the Linux box booted up fine with no errors, logged in as user account, ran Netscape browser and out to the internet!  We can even see the "penguin" share from his NT server!  Ping everyone ok, & they can ping back!  His NT server has the X-win32 application, which also saw the "penguin" share and allowed us to log into the linux environment from the WindowsNT machine!  (I thought that was pretty cool).  So I would like to say "Sorry" to all of you for not trying another building (hub location)earlier. We have several buildings here, with about 80 computers on our network, and I never thought that my Linux machine would not work with our hub since we have 8 Windows machines working on the same hub.  

I guess i should award points to someone, but who?  Can somebody please advise me on this one?  What is standard etiquette for help/user group sites?  If anything, I sure learned a lot about network cards.  The more I use Linux, the more comfortable I get with it.  I am confident that Linux offers features and reliability that my co-workers and myself never would expect from Microsoft Windows.
Thanks again.
0
patowicCommented:
I'd say delete the question, actually...

This was a hardware issue.  Either that, or award the points to the first person who said "check your hardware", which is arguably me, but I didn't go down the right track, so I shouldn't get all the points.  Drop the point value to 50, and award it to me, maybe?
0
gregchavezAuthor Commented:
Could not figure out how to delete... So I just awarded points.  Anyway you look at it, I still learned a lot with this, so it was still worth points.  Thanks.
0
patowicCommented:
Wow, thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.