Cannot open C: drive

When I click on my computer, and then click on the C: drive Icon, a game called Heratic wants to try and load. I deleted all the game files, and now when I click C: it says cannot find setup.exe. Instead of having a drive icon in front of C:, there is a window icon. How can I get the drive icon back, and be able to open my harddrive from my C: prompt.
kane99Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kane99Author Commented:
Adjusted points to 75
0
MrbreezeCommented:
Kane,
Try right clicking on it and choose Delete. Then reboot and see what it does.
Also you could try the system file checker to see if there is a corrupted file.
Go to Start,Run and type in SFC. That will scan your system files and prompt you to repair any it finds changed or corrupt.
                           Mrbreeze
0
BigMarkCommented:
Go to the start button and run c:
Open a view menu in any window, select options and then file types.  Scroll through the list and you will almost certainly find that there is an association between your c: and heretic.exe or something like that.

I think you'll find this will fix it.



BigMark
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

j2Commented:
i bet that you have a "autorun.inf" in the root of your c-drive (c:\) Delete it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dew_associatesCommented:
Kane, give thse a try:

First:
 
1. Click Start, point to Settings, and then click Folder Options.
 
2. On the File Types tab, click Drive, and then click Edit.
 
3. If "Find" is in bold, it is the default action. If it is not in bold, click
   Find and then Set Default.
 
4. Click Set Default to remove the default (using the Set Default command on the
   default action removes the default). Click Apply.
 
-OR-


Use Registry Editor to clear the Default value in the following registry key:
 
   HKEY_CLASSES_ROOT\DRIVE\SHELL

Let me know how you make out!
Dennis
0
kane99Author Commented:
How do I go about deleting the "autorun.inf" in the root of my c-drive
0
dew_associatesCommented:
If it's there, either by using Find, Files and Folders or Windows Explorer, right click on it and choose delete.
0
j2Commented:
or just

del c:\autorun.inf

from a cmd-window.
0
kane99Author Commented:
You hit the nail right on the head. Once the autorun was deleted, the C: drive went  back to its normal state. Thanks
0
j2Commented:
if you are interested.. the autorun.inf is the file that the OS looks for on a CD, to see what should get started when the CD is loaded into the drive. I don't know how you got on onto your harddisk, but it has happened to me aswell. In my case, i got the file on my e-drive, after misstyping a copy command.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.