• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 282
  • Last Modified:

Black Screen when leaving TP 6.0 programm

I have created a link from my win 98 desktop to a TP 6.0 DOS programm.
The DOS programm is working correct.
When I finish the DOS programm in normal way, my screen get black and I have to restrart my PC.
This problem is not every time I finish the programm.


What can I do to solve the problem.
0
thomaspeter
Asked:
thomaspeter
  • 2
  • 2
  • 2
  • +1
1 Solution
 
scrapdogCommented:
When inside TP 6, press ALT-ENTER to put the screen in a window.  To close it, click on the Close button (the Windows one).
0
 
lguiCommented:
First of all you must know if it's a problem of your program, your computer or your Win98 installation.

Do this:
- Install your program in another machine.
- Run it several times and see if the new computer freezes too.

If not:
- Try reinstall your Win98;
If the new computer freezes too:
- Try find on your code if you make some direct access to the memory or if you did not release some resources that you have previously allocated.

I hope help you.
0
 
thomaspeterAuthor Commented:
The problem occurs on different PCs.
I think it is a win 98 problem. Problably it is a problem of active desktop in win98.
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
lguiCommented:
Have you tested it on Win95 and DOS machines?

But, as you sad it don't happens every time you run the program, so you need to test sometimes.

Try an upgrade to win98 SE too.

If you want you can send me the source to take a look and test it.

lgui@epade.com.br
0
 
VIBESPROCommented:
this should work!

I had that error when I manually made a bat file to point to pascal..

it appears that the properties of the file are pointing to DOS and not to prevent it when in windows.

right click on the file 'turbo.exe'
and select properties. then click on program..

click on Run and select normal window.
then click on the advance button and select 'prevent MS-Dos based programs from detecting windows'  and select 'suggest MS-DOS mode as neccessary'

then click apply...

then click on memory on the properties
tab.. set all the options to "auto"

then click on 'screen' and select 'full screen'...

then run pascal again...

I did that when I used Windows 95
and now I use it with Windows 98 SE
and I just tried it and it works on my system.  It should work on anyone elses system too
0
 
thomaspeterAuthor Commented:
thank you for the answer.

you have sent me the standard properties to start a dos programm.

I am working 3 years on a win 95 machine
without any problem.


But the properties do not work on every win 98 system. probably there is a problem with the win 98 network.
0
 
VIBESPROCommented:
ok.. try updating Windows 98 and check out microsoft for more information..

when I installed Windows 98 SE I had now problems until I tried to restart in DOS..  My computer went into dos mode but my monitor went blank.  I got an update that corrected it.  

The best answer anyone can give is to check www.microsoft.com  for more information...  I'm sure you will fine your answer there.. ;)
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now