Can not ping the Windows or Linux Machine

I have been working on this problem for weeks now.  I am trying to be able to share Linux files with the Windows 98 box.

Problem:  
     I can not ping the Windows IP from Linux, and I can not ping the Linux IP from windows.

Information:
     I am running a DE-220PCT D-Link card in the Linux machine.  I loaded the NE 2000 compatible driver for the card on install.  When I do an ifconfig everything checks ok.  When I run a ping 127.0.0.1, all is well, and when I self ping the Linux IP from the Linux machine, everything is OK.
     I am not sure which card is in the Windows machine, but the driver that is loaded for it is a PCI ethernet DEC 21041 Based adapter.  The 127.0.0.1 ping and the self IP ping are both OK on the Windows box as well. The NETBEUI adapter is loaded on the Windows machine as well.  The Windows machine also functions well with the AT&T @HOME services.
     The hub that I am using is a Linksys 5 port hub with an uplink for the @HOME services.
     Samba is configured and running but no such luck on the Ping test or any visibility of the Linux machine on the Windows machine.


What do I need to do to fix the communication problem.  How do I trouble shoot the problem.  I feel that I haved tried everything.  I have listened to excellent advise but have gotten nowhere.  I need to fix this my self because I have tried to find others to help, yet nobody is familiar enough with Linux.



Thanks


Jason
browerjasonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lewisgCommented:
What are the IP addresses of the two machines?

Do you have a fixed IP address with the @home service?

Pings of loopback IP's 127.0.0.1 don't tell you very much. Run ifconfig, take note of the TX and RX packet numbers for eth0. Ping another address on the network - after 5 seconds press CTRL C to stop the ping. Ping should tell you how many packets it sent. Run ifconfig again, the TX packet number should be the ping count larger than before.

Also in ifconfig the eth0 section should have a HWaddr like 00:60:8c:23:5a:78. This is the MAC address of your ethernet card.
0
browerjasonAuthor Commented:
The IP address of the Linux machine is 192.168.1.1 and the IP of the Windows box is in the form of XX.X.XXX.X  (I would rather not give out the other IP).  Both masks are 255.255.255.0

Yes, I have a static IP at the moment, but will switch to dynamic later.  I don't plan to pay the extra money to get another @HOME IP for the Linux machine and am using the public domain instead (192.178.1.1).  At the moment, I just want to share Linux with Windows and don't care about having the Linux connected to the @HOME network directly.

When I pinged another IP on the Network from the Linux Box, there was 100% packet loss.  The results of the ifconfig showed that before the ping the TX count was 8613 and after the ping the count was 8623.  The difference is 10 even though the packet transfer from ping was only five packets.  Another ping and ifconfig showed 12 packets transfered, yet the TX increased by 62, not the amount of 12.

My HWaddr was 00:80:C8:FA:BA:85
By the way, what is a MAC address?

Jason

0
browerjasonAuthor Commented:
In the last note the public domain is 192.168.1.1 not the listed 192.78.1.1
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

lewisgCommented:
First the good news:
You finally appear to have a working network card in your linux box! The fact that linux can transmit packets and linux sees the Media Access Control address of you card is good.

Your problem has to do with the IP addresses. Unless you use routing both machines need to be on the same subnet. So if the linux box is 192.168.1.1 and the subnet mask is 255.255.255.0 the IP of other boxes on the subnet must be in the range of 192.168.1.1 thru 192.168.1.254. It is customary to use the .1 (your linux box's IP) for the gateway address for the subnet.

A bit of a problem isn't it? If you want to put both computers on the same subnet with a connection (non private IP) to the internet you have a IP subnet problem. I know of several solutions:

1. Get 2 IP addresses from @home and have both boxes on the internet.

2. Put 2 network cards in the Winbox. One to @home with their IP and one to the linux box with a valid IP for the subnet. Only the Winbox will be able to connect to the internet unless you load internet sharing software (Win98SE, WinGate, WinProxy...)

3. Put 2 network cards in the linux box. Sort of like the above but using IP masquerade and IPchains you could build a firewall/router and out everybody on the internet! (hey you already gave it the default router IP :)).

4. Put 2 network cards in an old 486 and install a package like sharethenet (www.sharethenet.com). I think this is your best solution since it is EASY and it allows for DHCP assigned IP (non-fixed) addresses and is a dandy firewall that will allow you to connect as many computers as you heart desires to the internet (very much like the above but easier and more secure).

5. There are ways to assign more that one IP address to a network card. I don't think it is a good idea...

So bottom line - if you want to ping and therefore be able to samba get your machines on the SAME subnet! (winbox IP 192.168.1.2)

later - Lewis
0
browerjasonAuthor Commented:
Holy Shmolly, you were 100% accurate Lewis!

This is what I have done:
     To reduce complications, I disconnected the @HOME uplink and set the IP of the Windows box as 192.168.1.2, rebooted the computer and low and behold, the Linux box magicly appears in Network Neighborhood.

Problems:
     When I double click the Linux icon, it asks me for a password.  I tried the root password as well as the unprivleged user password, by it replys with "Password incorrect".

Other notes:
     After looking at your 5 solutions to having the @HOME service working too, I think that I will pick #2, which will be to put another card in the Windows machine and run an internet sharing program like you suggested.(It seemed to be the easiest for me to work with??)  Eventually, maybe I will try #3, the firewall option, but for now I want to stick with simplicity.

Plans:
     I am going to Best Buy here in a bit to buy another card and extra RJ-45 cable.  I will install this hardware and wait for a response to this posting.  

Questions:
     How do I work around the password that it is asking for?  Also, what other suggestions do you have towards my plans this afternoon, and problems I may incounter with my chosen path?  If you think that it would be easier to put the card in the Linux box instead, let me know how to set it up and I will switch to that option after I purchase the card?


Thank you very much!


Jason
0
lewisgCommented:
Run smbadduser on the linux machine to create a user and password identical to the one you use when windows starts.

If you don't have another old computer around to set up sharethenet on, wingate or one of those programs will most likely fit you needs better than trying to set up ipmasquerade and ipchains for now.
0
browerjasonAuthor Commented:
Thanks for the great help.  It is running well at the moment.  It worked for about five minutes, I rebooted the Windows computer and then it vanished.  After rebooting Linux it reappeared??????????????????????  I can tell that the struggle is not quite over.


I have one more question before I let you off the hook, so to speak.  I increased points to 55, because that is all I have.  I want to know what I need to do to smb.conf so that my Windows computer has 100% access to all programs and files.  If possible I would like to operate the Linux machine completely from my Windows terminal.  I promise to close this question after this.  Thanks again,=. As a computer science student, I only hope that someday I can troubleshoot problems like you have in this case!  Thanks.


Jason
0
browerjasonAuthor Commented:
Ough I lied, I guess I had 10 points left, so here is the other 5.

Jason
0
lewisgCommented:
You don't need samba to operate linux from windows. Samba mostly allows linux to provide file and print services to SMB networks (mostly windows lanman) and vise versa.

To operate your linux machine from windows fire up telnet. (start menu, run enter "telnet 192.168.1.1" in the box and press enter) This will give you  access to all the text based programs and resources on your linux machine.

You may also want to check out:
http://www.uk.research.att.com/vnc/
I have not tried it out but it looks way cool!

Thanks for all your points - Good luck with your studies!
0
browerjasonAuthor Commented:
Thanks for the link and info.  I am going to leave this open until I see what may be causing my telnet to not work. (You are saying, god, why doesn't he close this!)  When I telnet the Linux IP, I come to a blank white screen, but no prompt??

Jason
0
browerjasonAuthor Commented:
Now if I wait for about 5 minutes the Login screen shows up.  When I try to type my login name, it prints double letters.  e.g. "jjaassoonn"  it does not do this with the password though??

Have the fixes??


Jason
0
browerjasonAuthor Commented:
I got it.  I realesed the Local echo and it works.  Thanks for everything Lewis.  Write back and let me know why the telnet access takes up to five minutes before I see a cursor??  This way when I get your response, I can press submit and the points will go to you!!


Thanks Again

Jason
0
lewisgCommented:
I don't know why telnet is so slow. I had the same problem a while back on one of my machines and I can't remember what fixed it!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
browerjasonAuthor Commented:
Thanks for the geat help in the past Lewis.  Good job, you have it running!

Jason
0
dewedCommented:
Since your working on a private network with no route to the internet I won't lecture anyone about using ssh instead
of telnet. but I will plug my favorite ssh program for windows, called putty   it also does telnet I think.
http://www.chiark.greenend.org.uk/~sgtatham/putty/

It might not help, but look at each systems hosts files.
Windows uses c:\HOSTS   just edit HOSTS.SAM save it as HOSTS with no extention. You may have to use DOS to ensure
it has no .tla at the end. Reboot to make it take effect.
Linux has a similar file, typicaly /etc/hosts  
Depending on what protocols your running it may make local ip/name lookups faster, but either way it shouldn't hurt.

Also, for whatever reason, I'm able to access my samba shares from my windows box, with only tcp/ip and the network card. You may have much more traffic/broadcasting going on, slowing down desired traffic.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.