Can't FTP

I'm having th is FTP problem.
Just installed Mandrake on my server and it runs beautifully but I can't FTP into it.

When I FTP I get this

220 linux FTP server (BeroFTPD 1.3.4(1) Sat May 1 16:04:03 CEST 1999) ready.
Name (<server>:<user>):
331 Password required for <user>.
Password:
530 Login incorrect.
Login failed.
ftp>

My password is not wrong as I've sent it to abcdef.
Help.

thanks.
dlim112899Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jprohartCommented:
Is your shell listed in /etc/shells ?
Do you try to connect as root or is the user listed in /etc/ftpusers ?
You must check that your user's shell is listed in /etc/shells and that the user's name is not in /etc/ftpusers, then retry to log-in.

Bye.
0
dlim112899Author Commented:
My shell is listed in /etc/shells.
And there is not /etc/ftpusers file.

I have been logging in as myself and not root.
0
jprohartCommented:
Do you use MD5 passwords ?
try to use passwords in /etc/passwd instead of /etc/shadow
(run pwunconv) then log-in.

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

budi_aCommented:
seems , the combination of user / password doesn't match.

try to passwd the user and
try to fpt again , now
with the new password, that have you changed.

and try to look in beroftpd log file ..
where do you send log file around. usually they go into /var/log/messages , try search for beroftpd[pid]:


regards

Budi Aditya
0
budi_aCommented:
sorry i forget to add , what is output
of beroftp log . so we can know
more precise about your problem.
0
dlim112899Author Commented:
This is the message from the log

Jan 14 16:08:44 linux ftpd[836]: USER desmond
Jan 14 16:08:48 linux ftpd[836]: PASS password
Jan 14 16:08:48 linux ftpd[836]: failed login from root @ localhost [127.0.0.1]$Jan 14 16:08:48 linux ftpd[836]: cmd failure - not logged in
Jan 14 16:08:48 linux ftpd[836]: SYST
Jan 14 16:09:12 linux ftpd[836]: QUIT
Jan 14 16:09:12 linux ftpd[836]: FTP session closed

How would I know if I'm using MD5?

Thanks
0
budi_aCommented:
hmm i think many of ftpd daemon ,
in default setting doesn't allow
root login ? ...

am i right ? ..

please try to log as a non root user.


regards

Budi Aditya
0
dlim112899Author Commented:
Okay, I have tried logging on from another terminal using myself as the login but I get this error message.

Jan 17 09:06:03 linux ftpd[7958]: USER desmond
Jan 17 09:06:15 linux ftpd[7958]: PASS password
Jan 17 09:06:15 linux ftpd[7958]: failed login from desmond @ <IP address> [<IP address>], desmond
Jan 17 09:06:15 linux ftpd[7958]: cmd failure - not logged in
Jan 17 09:06:15 linux ftpd[7958]: SYST
Jan 17 09:06:19 linux ftpd[7958]: QUIT
Jan 17 09:06:19 linux ftpd[7958]: FTP session closed                            
0
febbCommented:
Seems like a ftp security / configuration problem. you do not state your version, but for my RedHat -6.1- (quite the same as your Mandrakee) here it goes:  To make things easy and not going into the meaning and "secrets" of each of the file I mention, make sure of a couple of things:

1.-That there is no /etc/nologin file (it should NOT exist to allow logins -ftp and telnet-)

2.- That the file /etc/ftphosts is similar to:
# Example ftphosts access file
#
# Everything after a '#' is treated as comment,
# empty lines are ignored
#example on next line:
#allow  myusername      123.123.123.1
allow      username-who-will-ftpin      ip-of-host-you-will-ftp-from
allow      *      *
#deny *            *

3.- That /etc/hosts.allow and /etc/hosts.deny files are not impeding your ftp access. For testing purposes rename both (or delete them)  -if they exist at all- to /etc/bak.hosts.allow and /etc/bak.hosts.deny and try again, a combination of these 2 files with others mentioned in here may be the cause of trouble, be aware of that.

4. That the file /etc/ftpaccess ALSO permits use of the ftp service, one like this may work, use if for testing :
#/etc/ftpaccess file
class   all   real,guest,anonymous  *

email root@localhost

loginfails 5

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             all
tar             yes             all
chmod            no            guest,anonymous
delete            no            guest,anonymous
overwrite      no            guest,anonymous
rename            no            guest,anonymous

log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

passwd-check rfc822 warn


5.- This seems ok, but anyway, The /etc/services must have a line that is like:
ftp            21/tcp

6.- IDEM, The /etc/protocols should have a line like:
tcp      6      TCP    # transmission control protocol

7.- Lastly, the username you use to log in thru ftp must be a valid one, as well as it's password.

Hope this works.

Febb
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dlim112899Author Commented:
Hi Febb,

I'be tried all that you said but it still doesn't work?

Any other things I can change or do?

Is there a RPM package the has to go with BeroFTPD?

Thanks

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.