?
Solved

connect linux to win98 via SMB

Posted on 2000-01-14
14
Medium Priority
?
314 Views
Last Modified: 2011-09-20
well.
i´ve got a running SuSE 6.0 linux-system
and a _running_ win98 system.

after i successfully installed the ne2000 isa card in my linux-sys, i
naturally wanted it to communicate with
my win98-sys.

i don´t get any hint that there is a connection between these pc´s...

the cable is linked ;)
network-card initializes
the smb-server starts up.
routing fails (was kinda test 4 future)
ping linux>win98 fails. (net unrechable)
ping win98>linux fails.

guess there must be a config which i either don´t know or which i´ve configured wrong.

any hints where to start are apreciated.


thnx.

[KROM]
0
Comment
Question by:KROM
  • 6
  • 2
  • 2
  • +4
14 Comments
 

Expert Comment

by:budi_a
ID: 2353118
for more precise answer , please
include more information like :
output of dmesg , /sbin/ifconfig , /sbin/route. and

but from the info you give us ,
i think you don't succesfuly detected
ne 2000 card cause unmatch irq / io , or you not  activate your ethernet.  

first you must bring the network running before try in smb .. :)

regards

Budi Aditya

0
 
LVL 1

Expert Comment

by:jacoby
ID: 2353240
Budi is rite,

we need both infos from linux and win98 stations (assuming ur under TCP/IP, please report networks addr, netmask ...)

Jacoby.
0
 

Author Comment

by:KROM
ID: 2354282
well.
win98 uses IP 192.168.0.66
linux uses IP 192.168.0.99
it´s a tcp/ip net.

the card is succesfully detected, as there is no error shown on bootup.
also i can ping myself.


output dmesg:
(only the last lines, cause i think the rest is not of importance and i can´t copy&paste :)

NE*000 ethercard probe at 0x260: ** ** ** ** ** **
eth0: NE2000 found at 0x260, using IRQ 5

(i used "*" above cause i think this is the id of my card)

ifconfig:

lo: Link encap:Local Loopback
        .
        .
        .
dummy0: Link encap:Ethernet
         .
         .
         .
eth0: Link encap:Ethernet
      HWaddr: **:**:**:**:**:**:**
      inet addr: 192.168.0.99
      Bcast: 192.168.0.255
      Mask: 255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500
Metric: 1
RX packets:1 errors:0 dropped:0 overr:0
   frame:0
TX packets:0 errors:0 dropped:0 overr:0
   carrier:0 collisions:0
Interrupt:5 Base address:0x260


the win98 system has only tcp/ip, NetBEUI for both ne2000 and modem.
and file&printer-sharing.
network-card IS running.
i only set the IP-address to 192.168.0.66
gateway is off, also wins-server and dns

hope this helps a little bit :)

thnx!

[KROM]
0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 

Author Comment

by:KROM
ID: 2354303
at HWaddr: there is  " :** " too much
:)
0
 
LVL 1

Expert Comment

by:3408
ID: 2354434
I also think Budi is right.
You can ping yourself because it's a software loop. So package is never send by the NIC

3408
0
 

Author Comment

by:KROM
ID: 2354534
that means ?
the card _is_ installed. i´m sure.
cat /proc/dev/net say´s there´s a eth0
everything says there is a eth0.
sure there is a loopback too.
so what can i do ?
0
 

Author Comment

by:KROM
ID: 2354566
that means ?
the card _is_ installed. i´m sure.
cat /proc/dev/net say´s there´s a eth0
everything says there is a eth0.
sure there is a loopback too.
so what can i do ?
0
 
LVL 1

Expert Comment

by:3408
ID: 2354573
what do /proc/interrupts and /proc/ioports say about eth0? Do they match with your eth0 settings?

3408
0
 

Author Comment

by:KROM
ID: 2354587
they do
0
 
LVL 7

Expert Comment

by:lewisg
ID: 2355154
Are you sure the network wiring is good? Link lights come on on both cards for 10baseT, continuity and resistance testing for 10base2. If the wiring is faulty you usually get a "destination host unreachable" message.

I see in your original question it seems you are getting a "net unreachable" message. The only time I see this is when the IP's are on different subnets which from the IP's you have posted they are not.
0
 

Author Comment

by:KROM
ID: 2355677
the wire used to work fine... there´s no problem using it with two win-pc´s
the light on the backside of linux-ethernet-card is not flashing. but as far as i remember it only does when transfering data.
hmmm... any ideas left ?
0
 
LVL 7

Expert Comment

by:lewisg
ID: 2355884
The strange thing to me from what you have described is the "net unreachable" message that you get when you try to ping windows from linux. Is this the message you are getting?

Also could you describe the reason there is a section in ifconfig "dummy0: Link encap:Ethernet" Was this part of the "routing fails (was kinda test 4 future)" experiment?

My thought is that if you are really getting "net unreachable" from a ping to 192.168.0.66 the linux machine does not consider itself part of subnet 192.168.0.0.
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 100 total points
ID: 2356019
on win98>
route add 192.168.0.0 mask 255.255.255.0 192.168.0.66
0
 

Expert Comment

by:karim1
ID: 2376043
Hi,
In the past week I had the same problem, because I have only been working with linux around a year.

I network three computers by using a Hub, one netcard on each computer.

the first thing i did, was that to assign a private IP for each computer, you can do this by using th ifconfig command in linux:
192.168.0.1
192.168.0.2
192.168.0.3

the second thing is that i made loopback for each computer,so they can ping themselves.

the third thing is that in the computer with the IP 192.168.0.1 I configured it as a router:
route add -net 192.168.0.0 netmask 255.255.255.0 dev eth0

after setting up the router I ping the other computers:
ping 192.168.0.2
ping 192.168.0.3

if you get an answer, then you have your connections, but if not you have to check the physical connections to the hub, the cables, electric power to the hub, etc.

after that you can assign names to your computers so, you do not have to call them by their IP numbers, and you do that in the /etc/hosts file of each computer:
192.168.0.1   scooby
192.168.0.2   john
192.168.0.3   james

you can also do it in windows in a file named hosts.sam.

after doing all these you samba server should be working, unless you have problems with it.

I hope these is of some help for you.




0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Enter Foreign and Special Characters Enter characters you can't find on a keyboard using its ASCII code ... and learn how to make a handy reference for yourself using Excel ~ Use these codes in any Windows application! ... whether it is a Micr…
Suggested Courses

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question