How to run perl script

Hi all,
      I am trying to migrate a web page to different server. The problem i am having is that for some reason the perl script are not executed, that cretes the web page. You can check teh web site out @
http://ns1.foolhq.com/bugzilla/home.cgi
Here you will see the code. instead of actuall HTML code. I have verified the location of perl, it's correct. Any suggestion??

Thanks in advance.
atif555Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KennyIT Application ExecutiveCommented:
Firstly, you must be sure that the server allows you to run PERL scripts from the directory it is in (/bugzilla). Certain directories may not have execute access.

Secondly, your script has an extension of .cgi . The default extension for PERL scripts is .pl. Perhaps it does not recognise the scripts as PERL scripts because of the extension.

Hope it helps.
0
kawinCommented:
Hi atif,
      Your CGI script must put in /cgi-bin or other directory that you give excute permission (modify in httpd.conf ).

      Or use cgi-wrapper to allow other user in host to run their own CGI script (~/public_html/cgi-bin)

zxr250:
      Extension is not matter for CGI (C/Perl/Shell script). In unix if your file was excuteable it can run anyway.
      But if you have server site module like php it difference. It not CGI. File extension is told web server to start module to preprocess those script.

      I don't know about mod_perl (if you use).

Kawin.

0
atif555Author Commented:
Thank you Kawin to take the time and answer my question. I do have execution permition set on the directory. The permittion looks like "drwxrwxrwx" I did not understand about setting execution permittion in httpd.conf. Can you please explain this. How do i do this.

Thanks
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

atif555Author Commented:
Adjusted points to 90
0
KennyIT Application ExecutiveCommented:
Then, my last guess (I think) would be that the file itself does not have execute permission. Check to make sure that the file also has execute permission. The UNIX default for files is NO execute permission.
0
KennyIT Application ExecutiveCommented:
just in case, this is how you add the execute permission to a file in UNIX, I think :

chmod +x home.cgi
or
chmod 0555 home.cgi
0
kawinCommented:
Add this to your httpd.conf

<Location /bugzilla>
....

</Location>

Please read for apache document about Location keyword.

It can add "excuteable"..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
atif555Author Commented:
It needed to change permittion in the srm.conf. Anyway, thanks for you help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Perl

From novice to tech pro — start learning today.