Problems with autodial via ISDN

Hello !

If i configure ISDN to connect automatically to my provider/company i got the following problem:

If i open netscape(or telnet,...) and type an URL in the internet the connection is established automatically. But i got an error message by the application first (netscape, telnet) that i have no connection.  

Then the isdn-connection is on (after 3 seconds).

Then, if i click the second time 1-2 seconds later the application will work properly !

How can i solve this little Problem ?
mprobst111799Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

roaldCommented:
You must make the default route before logging in. If you use this line: 'route add default dev ippp0' after using 'ifup ippp0' you should get what you want. Also use that line in one of the scripts that get run when downing the line./etc/ppp/if-down.local .

Experiment a little and ask again if it doesn't work
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mprobst111799Author Commented:
I have set the default route and it works -- before.

Everything is fine; but see:

1. e.g. netscape www.yahoo.com
2. isdn tells me that its dailin
3. error message of netscape; no networkconn.
4. isdn is connectet
5. i type www.yahoo.com again
6. eyerything is fine

How do i get loss of no. 3 ?
0
roaldCommented:
Try removing the defaultroute-parameter in your script.

BTW,  could you give us the printout of ping <somehost>?

It might be interesting for you to look at some kind of proxy-program. I use wwwoffle and think it is great.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.