• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 176
  • Last Modified:

application question

when i run this application with java(i have compilled it with javac sucessfully) of JDK 1.2.2, it shows" Exception in Thread "main"java.lang.NoClassDeFoundError:TApplication"
The class is as following import java.awt.*;
import java.awt.event.*;

public class TApplication{
  public static void main(String args[])
/*    TMenu tMenu = new TMenu();
      new WindowAdapter(){
        public void windowClosing(WindowEvent e)
   ); */
   System.out.print("welcome to");
   System.out.println("java programming");
  • 2
1 Solution
does your classpath contain .?

check the filename is TApplication

(with case sensitive)  or not.

If Both filename and your java classname are same,then

check the classpath.

classpath = .;c:\jdkhome\lib\classes.zip;
( Pre 1.2 version )

where javahome is java installed directory.

Best of luck

iryAuthor Commented:
Edited text of question.
iryAuthor Commented:
Yes, I forgot to change the classpath in SHELL.
After i added classpath = .:.(BShell). Everything is OK.
Thanks a lot!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now