Red Hat 6.1 Networking

Once again - I'm an "expert" in Windows based computers, but when it comes to linux, I'm a novice (so I know what DHCP is, what an IRQ is and an I/O address).  That said, here's my problem:

On a Gateway 2000 P4D66 (486-66, upgraded with Pentium Overdrive chip (83 MHz), PCI Bus) I've managed to install Red Hat 6.1.  During the install process the 3c509b card I have was in the system, however, Red Hat never seemed to ask me about it (or networking in general - I did a Custom Install).  After rebooting, it was still not detected by any automatic means.  I went into X and the Kernel Configurator where I added eth0 as a 3c509, IRQ 10, IO 300.  I then went into networking control panel and set eth0 to activate on boot, obtain an IP through DHCP, and then tried to activate it there.  It gave me a message "Delaying eth0 initialization".  

I then rebooted and that too failed to start networking (as I understand Linux/Unix, most changes, especially like this, do NOT require a reboot.  Nevertheless, I tried).  I then downloaded the 3COM EtherDisk that allows me to configure the IO/IRQ of the NIC - I also verified that it was set to a non-pnp status.  The IRQ and IO were set correctly, but I decided to change them to 280 and 9.  That failed as well.  (I have tried 3 other 3c509 cards, none have worked, all have been set to 300/10 and non-pnp - all responded with the same message.  I then tried an SMC PCI NIC (DEC 21040 chip based NIC) which was detected through some pnp routines as a "tulip" based NIC.  This ALSO failed to automatically start.  BUT, for the duration of one boot, I was able to get it working - even after it failed to start on boot, it started ONCE successfully obtaining an IP address and putting me on the internet after I ran "netconfig" outside of X and told it to obtain a DHCP address.

However, since that one boot, I have been unable to get it to start again.  I would REALLY like to get this networking working - using ANY one of the 4 NICs I have tried!

FYI, my etc/conf.modules file reads as follows (now that I have both the SMC and a 3c509 card in):

options eth1 io=0x280 irq=9
alias eth1 3c509
alias eth0 tulip

Any/All help appreciated.
LVL 98
Lee W, MVPTechnology and Business Process AdvisorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
use a DOS boot floppy to boot to dos and use the 3c5x9cfg.exe to disable PnP on the 509. Set it to resources you know are free (IRQ 9 is NOT usable, neither is 2 sicne that is the cascade)

do NOT enter the i/o and IRQ for the 509 module, it should not need them.

it that still produces a "delaying eth..."

try hopping into linuxconf and "swap" eth0 and eth1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lee W, MVPTechnology and Business Process AdvisorAuthor Commented:
Actually, I got it working moments after I posted the question.  I actually debated with myself as to whether or not I should delete this question, but I figured, perhaps someone will tell me something I missed or just confirm what I did:

My solution - after looking in the Red Hat manual and seeing that, despite the option being present in the Linux config screen, according to the manual the only parameter to set is for IRQ.  So I set that and just left the I/O address out.  Rebooted twice now and it's come up both times, so I'm reasonably certain it'll continue to work.

So, your suggestion was correct.  (Though I had already used the "install" program available on the most recent drivers for this card (downloaded just hours ago from 3COM's web site) to change the settings from PNP and to manually set the IRQ/IO address.  Even with the correct IO in the config, it still didn't work.  Weird.  Leave the IO out and it works.  

Although, I should further point out that the SMC card worked once... but hasn't anymore... any clues on this one?  (Not terribly important to me, but if you have ideas...)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.