CD rom drive dissappeared!

Yesterday, I went to put a CD rom into my CD drive and it would not read it.  I went into my computer to check on the drive and to my shock it was not there!  I checked in the 'system properties' screen and its gone from there too.  When I boot up my computer it does not recognize it either as it used to.  I have no idea what happened to it.  The only odd thing that happened was that we had two brief moments of power loss at our house yesterday and the computer re-booted as a result.  Other than that I was using the drive earlier last week without any problems.  Now, how do I re-install the drive?  I tried the Add/Remove Hardware option, but it does not recognize it as a PnP device or as a non-PnP device.  Unfortunately I do not have a driver disk for the drive either as the drive is original to the computer.
BrergoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joedCommented:
check your CMOS BIOS settings and make sure the IDE that the cd is connected to is enabled. It is usually on the secondary IDE. If your PC is really old it could be attched to your sound card.
0
OttaCommented:
When you push the button on the front of the CD-ROM, does the tray open/close?
If not, then the CD-ROM isn't getting electrical power.

If it does, insert a CD, and rotate the CD so that you can read the lettering.
Close the tray.
Do you see any lights flash?
Do you hear the motor making the CD spin?
Open the tray, and see if the lettering is still oriented in exactly the same way.
If it is, then the motor is at fault.

> When I boot up my computer it does not recognize it either as it used to.

I was going to suggest this as the "next" step to take, but you've already tried this -- good.

Open the case, and check that the ribbon-cable between the motherboard and the CD-ROM is tightly-connected at each end.

If you get this far, and you have also tried JOED's suggestion, you can either pay a technician $30/hour to diagnose the problem ("your drive is dead"), or you can pay ~$30 to buy a brand-new CD-ROM.
0
BrergoAuthor Commented:
You are not going to believe this, but the drive is back.  I have no idea what happened.  I re-booted the system earlier and checked the bios settings to see if the IDE was enabled in the CMOS and it was.  I'm glad it is back, but am absolutely clueless as to what happened and why it wasn't being recognized by my system and now it is.  Any ideas as to what happened?  When it wasn't working, the tray was opening but the CD was not spinning.  The other thing I noticed earlier when the CD drive wasn't working was that my clock was set back by an hour.  I had to reset the clock in Windows.  I ran a virus scan w/ Norton Antivirus and it was negative.
0
MSSPs - Are you paying too much?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

biardCommented:
Sounds like a loose cable.
0
joedCommented:
When you enterd and exitted the BIOS it may have reset itself. Did you do a save when you exitted?
0
tazbotCommented:
To answer "Any ideas as to what happened <to allow the CD to be found again>?"

The most revealing part of the information you've given about this problem is 1) the change in your clock's time and 2) you did have a power outage.

Although joed has given you a short comment about how this may have "fixed itself" that I agree with, here's what I found with the PCs I helped develop BIOS software for from 1990-1994...

When there is a interruption in power, either from the wall outlet or the computer shutting down, the motherboard power circuitry is supposed to switch over to the battery which runs the clock and holds the BIOS settings.  If it does this "cleanly" your BIOS settings will stay completely intact.  If the switch to battery power was affected by an intermittent to the power on state, or the battery is getting weak, etc. it may have left the power switching logic in a CMOS RAM/battery/clock in a "middle" state.

It is possible that there could be no CMOS checksum errors on boot up if during boot time the reads, done by the BIOS, do return the correct values.  (The checksum used may only be a simple modulo 256 checksum where two errors can easily cancel one another out - I've seen it happen).

Although you may not see this problem occur again.... My recommendation is to check the battery.  Depending on the age of your computer it may be a coin cell, Dallas Semiconductor module, or just about anything the electronics guys could dream up to put on the board.
0
BrergoAuthor Commented:
No, I did not do a save and exit when I exited the BIOS.  So far, it is still working so I am happy.  Tazbot, thanks for the explanation.

Brian
0
tazbotCommented:
Sounds like there's no more need for the question to be active.

Glad to help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BrergoAuthor Commented:
Tazbot-

You're right...  thanks again.

Brian
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.