Launching StarOffice 5.1

At this point I don't think I even qualify as a "newbie".

I managed to install Linux 5.1 and StarOffice 5.1. I can not figure out how to launch the StarOffice application.

Can you help?

Thanks, Dave
dlehoullAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

edicomCommented:
well, open an xterm and launch soffice.
If it doesn t find it, maybe it s because your PATH var doesn t include the path where it is installed, you can then try #locate soffice (eventually launching updatedb before) and then adding it to your PATH var (export PATH=$PATH:/your_staroffice_path (probably /opt/Office5.1/bin)
Regards,
0
dlehoullAuthor Commented:
Please forgive my ignorance!

StarOffice is installed in /root/Office51. When I go into /root/Office51/bin, I find a file called soffice. I key it in at an nxterm prompt and nothing happens???
(Command not found)
I'm fine on my AS/400s, NT boxes and Novell boxes. Lost on Linux (so far):-)

Thanks, Dave
0
dlehoullAuthor Commented:
I'm certainly not in any position to "reject" any advice..but I'm not sure if I need to in order to "unlock" this thread for a little clarification.

Thanks again, Dave
0
edicomCommented:
then what about typing /root/Office51/bin/soffice in the xterm, or alternativly: cd /root/Office51/bin;./soffice
Or in the xterm, first typing:
export PATH=$PATH:/root/Office51/bin/soffice
And then launching soffice as previously.
The command not found comes from the fact that the system looks for executable in some directories only which are listed in the environment variable PATH. (the current directory is normally not included in it for security reasons). So you either have to explicitly say where the executable is to be found, or add the path to be searched for binaries.
Regards,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mgreinerCommented:
as you are working as root the problem is that
searching for progs in current directory is disabled.

cd into /root/Office51/bin and then type ./soffice

or change your path in /root/.bashrc or whatever you are
using as a shell as described before.

regards,
Markus
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.