Linux very slow?

I am a new user of Linux.  I find my newly installed RedHat Linux 6.1 is very slow in XWindow compared to win98.  I am using AMD-K6-2 333MHz computer which give me satisfactory speed in Win98.
However, the low speed may be due to some error in my setting.  When I running XWindow in console 7, I find the following error appear continuously in console 1:

ATARI device hdd:
Error: Not ready--(Sense key=0x02)
(reserved error code)--(asc=0x3a, ascq=0x01)
The failed "Test Unit Ready" packet command was:
"00 00 00 00 00 00 00 00 00 00 00 00"

This error keep appearing and my harddisk seem running all the time.  I think this cause my Xwindow running slow.
I have two harddisk.  Linux native and swap in the 4.3G c:.
d: is a FAT16 MSDOS formated with no system transferred.
When i install RedHat Linux 6.1, I have chosen both c and d driver to be available.

Could anyone help me?
Also, I can't find my FAT16 driver available for mounting in XWindow's mounting program.  How can i access my files in this driver?


kennon2000Asked:
Who is Participating?
 
nate_gooseConnect With a Mentor Commented:
I once had that problem because the kernal didn't see all of my ram.  You can try giving the kernal the paramiter to tell it how much there is.
This can be done at the lilo boot prompt like this:

LILO: linux mem=#M

If you have changed the default name for booting linux use it instead of linux in the example above.  # is the amount of REAL ram on your system in megabytes (a number, usually 8, 16, 32, 64, 128, ...).
If this works edit your /etc/lilo.conf file and add:

append "mem=#M"

in the section for the kernal that you are booting.
If you use loadlin.exe, there is a way to provide paramiters to the kernal, but I don't know it.

If this is the problem the reason for the slowness and disk access is that the kernal is swapping ram data to/from the swap parition to make up for the ram it doesn't know id there.
0
 
jamesRCommented:
Can you post a copy of you /etc/fstab file. Can you also run the 'mount' command in a console, and put up the output
0
 
EatEmAndSmileCommented:
RedHat is usually a very slow distribution. You should get a more robust distribution if performance is of your concern. I'd recommend Slackware, it's the most stable and easy-to-use distribution there is.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
patowicCommented:
Bah, redhat is plenty fast.  it's just insecure.  It looks like you may have some chipset problem, though.  I ran redhat 5.1 on a K6/200 and it was DAMN fast.  

Of course, if you've got KDE or gnome turned on, of course it will be slow.  Enlightenment window manager is a slow piece of cruft, too.
0
 
EatEmAndSmileCommented:
RedHat fast? Depends on which concept of "fast" you do have. But why not use faster stuff?
0
 
patowicCommented:
Okay, what parts of the kernel were changed to make the redhat kernel run slower than the slackware kernel?  What parts of glibc have been altered, to make it run slower than slackware?  What portions of xfree86 are different from other linux distributions?

If you're going to complain that it runs too many services, I have to ask:  why?  Services can be turned on or off in any distribution.

0
 
EatEmAndSmileCommented:
It's well know that RedHat (and it's son, Mandrake) run altered kernels, not the official kernels. These kernels are usually filled with everything they could find (but you won't use) and will result in a much slower system.

 Slackware, in the other hand, is modular, so all you gotta do when you need support for another piece of hardware is to edit /etc/rc.d/rc.modules and uncomment the line for it (no need to recompile the kernel) so you'll load only exactly what you're going to use.

 Talking about XFree86, RedHat miss the configuration tool, XF86Setup, replacing it for Xconfigurator, that doesn't allow you to do much, so optimization wouldn't be part of RedHat's reality.

 Among all these advantages, there's also the easy of use and the option to customize it the way you want, so your system might as well end up as cute as looking yourself in the mirror.
0
 
patowicCommented:
They do not generally alter the code.  They compile with more options.  This is why installing a stock source kernel is generally the best option.

This discussion is far beyond solving kennon2000's problem, EatEmAndSmile.  It has degenerated to your rabid Slackware advocacy (and that advocacy seems to be based in poor data and an unwillingless to check facts) against every other flavor.

Every flavor of linux supports customization.

Take your sermons somewhere else.  I will not respond to your ignorant claims of Slackware Supremacy any longer.

Kennon2000:  do you have your swap space activated?  (/sbin/swapon -s) will indicate whether you do or not.

What is your system load (you can check this at any command prompt with 'uptime')?

What model of hard drive do you have linux installed on?  How old is it?  Have you had any previous problems with it?

Have you run e2fsck in single user mode on your linux drive recently?
0
 
EatEmAndSmileCommented:
patowic: This discussion started because you complained about a simple comment I did. Seems also that you've taken it to the emotional way, not the intelectual way. I won't continue explaining why I've chosen Slackware, you might as well check out www.slackware.com under the "About" section.

kennon2000: Regardless of which distribution you're using, you may have some other problems that make your machine slower. Where did you notice the slow down? In console mode or X Windows System? Are you using a window manager (like Window Maker) or a full desktop environment (like Gnome)? If your video board was not well configured, it can also make X slow down. Which video adapter do you have?
0
 
nate_gooseCommented:
About the difference in distributions and speed:
Red Hat also uses modules.  It also includes xf86config.
I don't think that xf86setup was concidered stable when RH 6.1 was released.  ( may be wrong about xf86setup )
0
 
patowicCommented:
Redhat 6.1 uses the 2.2.x kernels, which I seem to remember automatically recognize fairly large quantities of RAM--up to 128M anyway...
0
 
EatEmAndSmileCommented:
Look to this:

ATARI device hdd:
                         Error: Not ready--(Sense key=0x02)
                         (reserved error code)--(asc=0x3a, ascq=0x01)
                         The failed "Test Unit Ready" packet command was:
                         "00 00 00 00 00 00 00 00 00 00 00 00"

 I was told this error happens if your IDE controller is not fully supported by the kernel version you're using. I've also heard that some kernel families used to have a bug that would generate this error a lot. Maybe an upgrade could solve your problem... Isn't RedHat 6.2 or higher out?
0
 
kennon2000Author Commented:
Thank for the sincere comments from all experts.  It seem that the hardware compatabliity or detection ability of Linux is not better than Windows.  Apart from this error, my software modem seem not to be accepted by RH also.
I am sorry that I am working busily during weekdays.  I will try to solve the problem this weekend after getting all your suggestion and see which is the real answer.
Also, I have:
196MB SDRAM
Display card: Trident 9440 PCI VGA
0
 
EatEmAndSmileCommented:
Hardware detection is not a good idea regardless of the operating system. RedHat tries to turn Linux into another Windows contender, but if you really want your PC to work correctly, there's no better solution than grab that lil' manual that came with your hardware piece and read it's specifications. Then all you gotta do is enter these values into the software. Piece of cake, faultless results.
0
All Courses

From novice to tech pro — start learning today.