ethernet, dos2unix, tar, printer

Help!!!
Ok, I have a few issues here.
1. I cannot get my linksys 10/100 ethernet card to work. I've downloaded tulip.c, but cannot get it to compile, which brings me to my next problem.
2. I cannot get my dos2unix program to install using rpm. On the command line I type rpm -i -v dos2unix-blah-blah.src.rpm When the debugging info comes up it shows that it finds 1 program to install, but then it says that it can't find anything to download?

3. I cannot get my x-windows to work. I have the SiS530 video card. I just ftp'd over the newest version of xfree86, and uncompressed all the files using gzip -d. This left me with a bunch of .tar files that I cannot seem to uncompress. I try using tar -x *.tar, and tar -x filename.tar and both just hang. I see the preinst.sh file, but don't know what to do with it.

4. My printer does not work. I am using a HP deskjet 710c. When I try to print something, I don't get an error, and it tells me the file is printing, but nothing comes out? heheh

I know I'm asking a lot here. I'de really appreciate it if you guys can help me out (If I have to ask one of the guys on campus for help I'll never hear the end of it)

Oh ... by the way, I'm using Mandrake 6.something
scottd1978Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

biardCommented:
1)  Verify that the source code for your current kernel version is installed.
If you don't have a /usr/include/linux/version.h file, do
cd /usr/src/linux; make include/linux/version.h
Copy the driver source code to a source directory. I usually use /usr/src/modules/tulip.c.
Compile the file using the compile-command at the bottom of the tulip.c source file.
As 'root', load the module using "insmod tulip.o". You should first test this by hand in single-user mode. If it works as expected you should add the insmod command to /etc/rc.d/rc.inet1 or /etc/rc.d/rc.local.


2)  Two problems.  You have the source rpm, not the rpm.  Click the BIG BLUE LINK at the top of this page:

http://www.userfriendly.net/linux/RPM/contrib/libc5/i386/dos2unix-2.2-4.i386.html

Then use the command:  rpm -ivh dos2unix-2.2-4.i386.rpm


3) Use the command:  tar -xvf *.tar

4) Not sure that that particular printer is supported.  Tackle the other 3 and then we'll see about the printer.
0
scottd1978Author Commented:
1) Got the dos2Unix to install -- thanks
2) After following your instructions to create the tulip.o file, and trying to use the insmod tulip.o I get one of 2 errors.
    1) init_module: Device or resource  busy
    2) tulip.o: unresolved symbol somename (this one shows a lot of the same error with different values for somename)

3) tar -xvf *.tar gives me the following error:
   filename.tar not found in archive ... this also happens many times.
0
themCommented:
Please provide a copy of the output of the following commands:

1) cat /proc/modules
2) cat /proc/interrupts
3) cat /proc/ioports
4) cat /etc/config.modules

That will give me enough info to help you get the network card going.


0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

scottd1978Author Commented:
cat /proc/modules
nls_iso8859-1           2052   1 (autoclean)
nls_cp437               3580   1 (autoclean)
vfat                   11036   1 (autoclean)
fat                    32960   1 (autoclean) [vfat]

cat /proc/interrupts
           CPU0      
  0:       7978          XT-PIC  timer
  1:        251          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  8:          1          XT-PIC  rtc
 12:          4          XT-PIC  PS/2 Mouse
 13:          0          XT-PIC  fpu
 14:      43760          XT-PIC  ide0
 15:         30          XT-PIC  ide1
NMI:          0

cat /proc/ioports
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial(auto)
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
4000-4007 : ide0
4008-400f : ide1

cat /etc/conf.modules
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start

0
biardCommented:
The problem with the tar command is that the archive is incomplete. Your download must be corrupted or incomplete.  The tar archive holds a header which marks all included files and positions.  It attempts to extract them all, whether there or not.  If they are missing, this error is reported.  So, you need to download your archive again.  Sorry.
0
themCommented:
Is the linksys card you are using a pcmcia card? If so "su -" to root and try running:

/etc/rc.d/init.d/pcmcia start

After doing this please provide the following dumps:

1) cat /proc/modules
2) cat /proc/interrupts

Bringing up a pcmcia card is easy if the pcmcia services are running and yours are not from the data dumps you provided.
0
scottd1978Author Commented:
It's not a pcmcia card ... I'm going to try ftp'in again.  I appreciate your help on this.
0
themCommented:
1) Add a line to /etc/conf.modules

alias eth0 tulip

2) Then as root

insmod tulip

3) cat /proc/modules
4) cat /proc/interrupts

0
scottd1978Author Commented:
Did this ... (Still haven't redownloaded) and I get this error:
/lib/modules/2.2.13-7mdk/net/tulip.o: init_module: Device or resource busy

cat /proc/modules
nls_iso8859-1           2052   1 (autoclean)
nls_cp437               3580   1 (autoclean)
vfat                   11036   1 (autoclean)
fat                    32960   1 (autoclean) [vfat]

cat /proc/interrupts
           CPU0      
  0:      10784          XT-PIC  timer
  1:        354          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  8:          1          XT-PIC  rtc
 12:          1          XT-PIC  PS/2 Mouse
 13:          0          XT-PIC  fpu
 14:      43837          XT-PIC  ide0
 15:         30          XT-PIC  ide1
NMI:          0
0
themCommented:
Hmm, still did not load the module. I'll have to sleep on this a bit. What version of the kernel are you using?

cat /proc/version

0
scottd1978Author Commented:
cat /proc/version

Linux version 2.2.13-7mdk (root@kenobi.mandrakesoft.com) (gcc version 2.95.1 19990816 (release)) #1 Wed Sep 15 18:02:18 CEST 1999
0
gruseCommented:
Think I can resolve the "tar" issue.
If you type "tar -xvf *.tar" and you have *several* files ending in .tar in your directory (say, file1.tar, file2.tar and file3.tar), your command line resolves into "tar -xvf file1.tar file2.tar file3.tar", meaning that you want to extract file2.tar and file3.tar out of file1.tar.

You can try "tar -xvf file1.tar; tar -xvf file2.tar; tar -xvf file3.tar", or

for I in *.tar; do tar -xvf $I ; done

In the first case, you just enter all the filenames by hand, the second is a simple loop going over every file that ends in .tar and calling tar -xvf for it.

Good luck with your other problems!
0
gruseCommented:
Ah, I knew I forgot something the moment I clicked "Submit" ... B-(

Files ending in .sh (as your preinst.sh) are shell scripts. You can read them in your favorite editor or by typing "less preinst.sh" to see what they do. If you want to run it, go to the directory where it lives and enter

sh preinst.sh

That should work in every case. There, now that part's *really* done, I hope B^)
0
scottd1978Author Commented:
Round 7

Ok, got the sh preinst.sh set-up, but when I try to do the tar as listed by gruse, I get an error saying cannot chown on lot's of files.  I'm in as root.  I tried both ways.  Are there books for this stuff?
0
biardCommented:
You should have man pages.  Try

man tar
man chown

etc...
0
gruseCommented:
Well, apart from the fact that not being able to chown some files (even a lot) shouldn't be too critical for just unpacking and compiling some source, there are two possibilities I can think of.

First, on what kind of filesystem did you put your tar files in the first place? If they reside on a vfat or dos filesystem, you can't change ownership of files because the underlying filesystem does not support changing ownership of files. Files on those filesystems get a default owner, either by using specific mount options or by using the owner of the directory where the file system is mounted.


Second, did the tar archives get unpacked, and only chowning them failed, or didn't they unpack? Then you might have your filesystem (where the tar files lie) mounted read-only. A common ocurrence (to me, at least). Maybe you had those files on an ntfs filesystem, that *has to be* read-only. Well, you can try to mount it read-write, but that feature is *experimental*, and if you value your data as I do, you don't want to take that risk.

Remedy in both cases is easy: Move the tar files into a filesystem that is a) read-write and b) of type ext2.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
scottd1978Author Commented:
wooohooo ... thanks gruse.  I had those files in my windows partition.  After I moved them, the unpacked nicely.  I then ran the postinst.sh and then xf86config.  At first it gave me an error with the symolic link ... /etc/X11/X.  For some reason the config prog set the link wrong.  Once I changed that the x fired up (besides the extremely large kde desktop everythings cool).  Woohoo!  I wish I could give out points to each person that solved a problem in here so far.  Is that possible?  If I could just get my ethernet to work now ...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.