FTP connection refused by server

I am using Red Hat Linux 6.1 in our organisation. We use it
for file transfers only.  Our problem is when more than 60
users login for doing FTP simultaneously, they start getting message as 'Connection refused..' and they are not able to connect for next 15-20 minutes or until server is restarted. Kindly suggest me solution for this problem the soonest possible as it is one of our time critical project.
kc2607Asked:
Who is Participating?
 
ramvinodConnect With a Mentor Commented:
add the user's shell in /etc/shells and check in inetd.conf whether the line for ftpd is "NOT" remarked.
0
 
RobWMartinCommented:
Since I haven't used Red Hat in years, I don't know what its default ftpd installation looks like.  Thus, this may be useless to you.

If you have a file in /etc called ftpaccess, look for a line that starts with the word, "limit."  The numbered argument to this directive is the max number of users of a specified class during a specified time period.  IF you have this file with a limit directive, you can change the limit.  Or, if you don't have other "important" directives in the ftpaccess file, you can just tell ftpd not to use the ftpaccess file.  Do this with the -A option when starting ftpd.  -A is usually the default, though, so you may need to remove the -a (i.e. lower case) option.  The -a option tells ftpd to use the ftpaccess file.

Hope this helps!
0
 
kc2607Author Commented:
We have already tried solutions as explained in the answer (putting -A and /or removing -a in ftpd). Neither of them works. Kindly help us further what more we can do.

Wating.
Kailash Joshi
0
All Courses

From novice to tech pro — start learning today.