xdm

Hi....

have installed RedHat Linux and want to use it via WRQ Reflection on a PC in a local network. XDMCP Broadcast brings a list of XDMCP-hosts but my new RedHat sys is not there. I can telnet into it, it is reachable.

Starting xdm on linux results in (error-file)

xdm error (pid 7059): error 98 binding socket address 177

Fatal server error:
Server is already active for display 0
        If this server is no longer running, remove /tmp/.X0-lock
        and start again.


When reporting a problem related to a server crash, please send
the full server output, not just the last messages

xdm error (pid 7059): server unexpectedly died
xdm error (pid 7059): Server for display :0 can't be started, session disabled


What can I do ? :-)
hitzeuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

biardCommented:
You need to export the DISPLAY environment variable to your machine.  After you telnet in to the server, type:

export DISPLAY=yourip:0

where yourip is the ip of the machine you are on.  Then try to just run xterm.  You can start your gui from there.
0
hitzeuAuthor Commented:
Thank you :-)
This is a workaround.
Any idea why the machine cannot respond to the xdmcp-broadcast / direct xdmcp?
0
biardCommented:
Well, I use both in conjucntion with one another.  For some reason, my X-win32, using XDMCP broadcast still requires that the DISPLAY environment variable be set correctly.  Everytime I connect, it is sort of a 2-step process.  I guess I could write a batch file, but it isn't really that big a deal.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

jyu_88Commented:
/etc/X11/xdm/Xaccess defines access control for XDMCP connections. lots of comments inside, and you should able to configure it to your like then either restart XDM or send a HUP signal to the original i.e. parent xdm process (ps -alef|grep xdm and the smallest pid should be the one)

Also, kdm works pretty nicely but gdm from stock RH6.1 installation is not. gdm2beta or newer should works better. If you are using plain old xdm, then I guess you are fine.

also, different window managers works different when access through XDMCP. kde works best for me.

You are attempt to start xdm. in your case, X server on your PC is asking the remote linux server to manage the PC x server's display, thus the name XDMCP (x display management communication protocol).
0
jyu_88Commented:
text editing for my last paragraph of my previous comment. The first sentence should be changed to: "You are not supposed to start a new process for remote xdm since as the error indicated it is probably running already.  You are merely asking an instance of that running xmd to talk to your PC x server."
0
jyu_88Commented:
text editing for my last paragraph of my previous comment. The first sentence should be changed to: "You are not supposed to start a new process for remote xdm since as the error indicated it is probably running already.  You are merely asking an instance of that running remote xdm to talk to your PC x server."
0
jebrightCommented:
What init level are you running at? try typing runlevel at a terminal prompt, if it is not 5, then XDM (or a relative like KDM) will not be running! (and you were essentially tryiong to start another X session on the same vt). To fix this edit (very carefully after backing up the file and/or system):
/etc/inittab
look towards the top for a default line like:

id:3:initdefault

Change the 3 to a 5 (this will fix it for the next reboot) and to apply immediately, exit xwindows, then type:
telinit 5
You should now get a XDM login window.

To test from another linux box try something like:
startx -- :1 -query <hostname or ip here>

This will start it on vt 1 (Ctr + Alt + F1)

Try startx -- :2 -broadcast to check out the XDM on vt 2.


0
hitzeuAuthor Commented:
Runlevel is 5.

I can telnet into linux from PC(open Reflection), set DISPLAY and type kde --- it works.

But Broadcast doesn't find the machine.
0
jyu_88Commented:
Did you read my comments above about /etc/X11/xdm/Xaccess on your Linux box.  I am pretty sure that's the problem you are having.
0
jebrightCommented:
Sounds like a problem with reflection then.... did you try the start suggestion (query, then broadcast) from another linux box....

You do not need to tinker with the Xaccess file in Redhat, it works fine as is by default for what you want to do.

Also try makeing the prefxdm link into a link to xdm directly.

Have you tried  perhaps using ssh to login to the linux box and use Xauth (in ssh) to open the xsession on your PC. This works well with Xwin32 and Secure CRT.
0
xtek121499Commented:
1. goto /etc/X11/gdm
2. edit gdm.conf
3. change the value of Enable to 1 in [xdmcp] section
4. if not solved, you should upgrade your gdm package.

try it with Xmanager, another X server.
you can download it from www.download.com.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hitzeuAuthor Commented:
Did not work. I will upgrade gdm.
(Still wondering...)

Thank you
0
jyu_88Commented:
look at your /etc/X11/xdm/Xaccess
and my previous comments.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.