Zip drive install adding additional Floppy drive designator

I have a Windows95 Pentium with a floppy dirve (A:), two harddrives (C: - Master) and (D:-slave) connected to IDE1, a Creative CDROM hooked directly up to a Soundblaster 16 Card and a iomega Zip drive (internal) connected to IDE2 on my motherboard. The Harddrives and Zip drive are auto detected at bootup time.
MY PROBLEM:
My PC does not recognize the zip drive (does not assign a drive letter) and after installing it. then I noticed that Windows device manager (and explorer) shows an additional floppy drive designator icon (B:). If I click on the drive letter, after a moment, it says, "device not ready..." (this happens regardless of whether I have a disk in the A: floppy or not) - The A: floppy works OK.
I have tried removing the device (B:) via the device manager, but when I reboot, the second drive letter always comes back. Note, there are no conflicts, and if I physically remove the Zip drive, the second letter does not appear at bootup and everything is fine.
Anyone have any ideas on how to get my zip a drive letter and at the same time getting rid of the 2nd floppy designator?
ramooreAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
MrbreezeConnect With a Mentor Commented:
Ramoore,
One of the links you gave does lead to drivers but they are for a FIC brand board. Do you know the brabd name of your motherboard? Look on it and see if you can see a name. Or maybe a FCC ID# written on the board. The drivers are made not only for the chipset but also for the board. Some go on any board some only go on the boards they came with.
I am still looking at VIA's site so I'll let you know what I find
                         Mrbreeze

Sure you don't just want to upgrade to Win98?...LOL
0
 
rjthorntonCommented:
It sounds as thou your pc bios will not support the zip drive. Therefore in order for it to be available in dos or windows you must use the drivers supplied with the drive. The newer pcs recognize the zip drive at bios level, however the pentium and earlier class did not.
0
 
ramooreAuthor Commented:
Thanks for responding, Your answer sounds right, but before accepting, I need some clarification.. You mention that I should use the drivers that are supplied with the drive. Are you referring to the drivers on the manufacturers CDROM? If this is what you mean, then I am already using them and there must be no way around my dilemma. Is this correct to you?
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
MrbreezeCommented:
Ramoore,
It doesn't mean that the problem is hopeless, it just means we haven't found it yet.
You said that the drives are auto detected at boot. The BIOS should not be set to detect your drive, you only want it detected by Windows.
Try this
1)Go into BIOS
2)Choose the setting for Standard CMOS
3)Scroll down with the arrow keys to the Secondary channel and using the pgup & pgdn buttons change the Secondary Master to none in the type selection.
4)Press ESC and choose Exit and Save
5)Tell it Y
It should continue to boot and you should have a new drive show up in My Computer.
Let me know if that works and if not we can try a couple other things.
                          Mrbreeze
0
 
biardCommented:
Actually, there were some issues in the past year or so that arose regarding Zip drives appearing as drive B:.  This was largely due to incompatibilities between system board BIOS and the imm scsi emulation controller in the zip drive itself.  Usually, the drive would function properly as B:.  However, in some cases, they would read, write, and format fine, but would not be able to be read on other machines.  I even saw some format at 400 MB.  Still others did not read at all.  I believe that in order to solve this issue, you will need to locate an updated BIOS flash for your mother board.  If you can locate the BIOS chip and give us the brand and version (or by booting into setup instead of opening case), post it here, and we will help you find a flash upgrade if one is available.  Otherwise, you may need to get an external Zip drive instead.
0
 
rjthorntonCommented:
NO Im not refering to the cdrom drivers, in older system you can to use the drivers or an executable to enable the zip drive. In the newer systems, you can set the zip in the bios as a removable or zip or iomega drive. I agree that is should not be set to auto as well. With the newer machines, it does appear as floppy B in explorer and my computer. First thing I would do it double check your bios for any of what I mentioned then more to the drivers disk for the zip drive itself.
0
 
biardCommented:
Dude, how about just posting some comments already?
0
 
MrbreezeCommented:
Rj,
I'm not sure if your intent was to post an answer or a comment. It appears that you are suggesting that he flash his BIOS to make it recognize the Zip drive and he has already stated that his BIOS is detecting the drive so I don't see the relevence. The Iomega should not be set in BIOS to detect the drive it is the OS that needs to see it as I posted from Iomega's manual

Make sure your computer's BIOS is not controlling your Zip ATAPI drive

The Zip ATAPI and Zip Notebook drives are supported by drivers loaded with the operating system. If your computer's BIOS is controlling your drive, these drivers may not detect or control the drive properly, and your drive may not be recognized or function properly

Ramoore can choose a comment as an answer if he feels that it offers the best solution to his problem.
                      Mrbreeze
0
 
rjthorntonCommented:
Yes I meant to place a comment, and if you look at the first line in the problem, it said.
My PC does not recognize the zip drive (does not assign a drive letter)
but windows does, so like both you said before, it appears to be a bios issue.
0
 
rjthorntonCommented:
P.s. I had now intension of upsetting anyone, it was an honest mistake, I think we all agree that the problem is bios or driver related, if the bios wont support then drivers have to used, if the bios does support it, then it has too be configured properly.
Sorry again.
Rob
0
 
MrbreezeCommented:
"The Harddrives and Zip drive are auto detected at bootup time"
That is the BIOS detecting the drive

MY PROBLEM:
My PC does not recognize the zip drive (does not assign a drive letter) and after installing it.

That is the OS not recognizing it. The OS is the one that assigns the letters and that is why I suggested the solution I did.
I wasn't trying to insult you about the way you posted, as I stated. The important thing is to help resolve the problem Ramoore is having and I think that is what we are all after.
                       Mrbreeze
0
 
rjthorntonCommented:
ramoore, this may seem like a silly question but humor me.
When you clicked on the B drive, did you have a disk in the zip drive. I noticed that you had a disk in your A drive but you didnt mention if there was one in the zip drive. Atapi/Ide zips will appear as floppies so that they dont upset the logical or cdrom drive letters.
0
 
ramooreAuthor Commented:
Yes, I had a disk in the Zip drive when I clicked on it.
0
 
sorgieCommented:
I have pretty much the same setup and Mrbreeze is on the right track. Don't let the Bios auto detect the zip. Leave it to none and let windows recognize it.
Make sure you delete all references to the zip in device manager before rebooting.
0
 
ramooreAuthor Commented:
To Mrbreeze:
I went to the BIOS and changed it to not find any drives (no auto find), or the Zip and then saved it. the PC rebooted and here's what I found out:
1) During reboot, the PC showed it found the Zip drive ("Found Atapi device: Iomega Zip100")
2) I went to My Computer and it still showed 2 floppy drive icons (A: & B:).
3) I clicked on the B: drive and I received the message: "B: not accessible - Device not ready"
4) I looked in Device Manager and there is a Yellow dot with a ! sign. I clicked on it, and found no conflicts. I said the device was either not working properly or the drivers were not installed (they are).
Note, after removing the second floppy (b:) via the device manager, it comes back again at reboot time.
-thanks.
0
 
MrbreezeCommented:
Try this and it will tell us if we are having a software or hardware problem.

1)Restart the machine and press F8 when you see Starting Windows 98

2)Choose Safe mode command prompt only from the Windows boot menu.

3)At the C:\ prompt type
progra~1\iomega\tools\guest
and press the Enter key. Guest will assign a drive letter to your Zip® drive.

4)Test your drive in by inserting a disk and try to access it.

Since you have two hard drives and a CD it probably will show up as E: or F:

Let us know what that does
                         Mrbreeze

0
 
MrbreezeCommented:
Ramoore,
Check to be sure you have the Zip set as a master drive. Since it is the only drive on IDE2 it needs to be jumpered as master, it comes from the factory set at slave. Looking at the back of the drive the jumper should be over the two pins farthest to the right, not the middle ones.
                      Mrbreeze
0
 
ramooreAuthor Commented:
Mrbreeze:
Things are getting better...
1) The Zip was on the master setting.
2) I went to Safe mode and ran the Guest.exe. The system assigned the Zip a drive letter (H:).
3) While still in Safe mode (at the DOS prompt) I actually copied some files from C: to the Zip drive (H:) . Just to make sure, I changed the dir to H: and saw the files listed. Great!
4) Next, I rebooted into Regular Windows and looked for the H: drive, but there wasn't any. (just the same old 2 floppy drive letters (A: and B:).
0
 
MrbreezeCommented:
Ramoore,
Progress. it isn't hardware so now we need to figure out what software is being crazy.
Make sure you have the latest version of VOLTRACK.VXD and ESDI_506.PDR

1)Double click My Computer
2)Double-click on the C: drive icon
3)Within the C: drive open the folder windows\system\
4)Double click on the iosubsys folder.
5)Within the iosubsys folder, locate the files ESDI_506.PDR and VOLTRACK.VXD.
6)Right click on ESDI_506.PDR and choose Properties.
7)Click on the Version tab. The File version should be 4.00.112 or newer.
8)Right click on VOLTRACK.VXD and choose Properties.
9)Click on the Version tab. The file version should be 4.00.111 or newer.

If either of these files is not current you can down load and install the current version of the files from Microsoft's web page. http://support.microsoft.com/support/downloads/dp2884.asp

Lets see what you got in there

Verify the bus mastering IDE controller date is 08-24-98 or newer

1)Open Device Manager by selecting Start, point to Settings, and then click on Control Panel.
2)Within the Control Panel, double-click on the System icon.
3)Within the System Properties screen choose the Device Manager tab.
4)Click on the plus(+) symbol next to Hard drive controllers.
5)Since your Zip drive is connected to the Secondary IDE controller, double-click on the Secondary IDE controller.
6)Choose the Driver tab. If the Date is earlier than 8-24-96, you will need to obtain an updated driver from your motherboard manufacturer.
                    Mrbreeze
0
 
ramooreAuthor Commented:
Mrbreeze:
Here's the steps and results:
1) I found the two files. The ESDI_506.PDR is version 4.00.112, the VOLTRACK.VXD is version 4.00.953.
2) I went to device manager to try and verify the bus mastering IDE controller date per your instructions...
I clicked on the + symbol and double clicked on the Secondary IDE Controller, but found no "Device" tab. All there is, is a "General" tab and a "Resources" tab. On the General tab, it shows three fields or sections: 1) Device Type: Hard Drive Controller, 2) Manufacturer: Standard Hard Disk Controller, 3) Hardware Version: Not Available.
What is your opinion? I'm thinking it may be difficult to get an updated driver for my motherboard (Award Modular 4.51PG??) manufacturer, since it's probably too old (1995-96). I appreciate your information so far.
0
 
MrbreezeCommented:
Ramoore,
"but found no "Device" tab". You meant this to say "driver" right. Ok theres a problem, there is no driver on the channel. Do the same thing with the Primary channel and see what you get there.

1)Open Device Manager by selecting Start, point to Settings, and then click on Control Panel.
2)Within the Control Panel, double-click on the System icon.
3)Within the System Properties screen choose the Device Manager tab.
4)Click on the plus(+) symbol next to Hard drive controllers.
5)Double click on the Primary IDE controller.
6)Choose the Driver tab.  

The drivers should be coming from Windows so the motherboard people may not need to get involved yet.
                 Mrbreeze
0
 
ramooreAuthor Commented:
This is a test. My comments don't seem to be showing up anymore.
0
 
ramooreAuthor Commented:
I apologize if this comment is appearing multiple times. It did not appear for me.
All the Conrollers have only a Resources and General tab. I actually have 3 entries under Hard Disk Controllers:
1) Primary IDE controller (Single fifo)
2) Seconday IDE controller (Single fifo)
3) Standard Dual PCI IDE controller (hardware version 002)
0
 
MrbreezeCommented:
Ramoore,
Thats not good. Try this
1)Click Start,Settings,Control Panel, and then double click System.
2)Click the Device Manager tab.
3)Click the + sign next to Hard Disk Controllers
4)Click the Standard Dual PCI IDE controller (hardware version 002)
5)Click Properties.
6)Click the Settings tab.
7)In the Dual IDE Channel Settings box, click Both IDE Channels Enabled, and then click OK.
8)Click OK, and then restart your computer.
 When it reboots go back to Device Manager and see if the entries
Primary IDE controller (Single fifo)
Seconday IDE controller (Single fifo)
now say
Primary IDE controller (Dual fifo)
Seconday IDE controller (Dual fifo)

I have to check to see if Win95 has updated Bus drivers.
If not the only other thing I could suggest is to try putting the Zip as slave to your C: drive and see if it works. The best cure would be to upgrade the OS to Win98. If you are using Win95 version 4.50a you probably won't get it to work in your machine.
                 Let me know what happens from this post
                        Mrbreeze
0
 
ramooreAuthor Commented:
Mrbreeze:
Here's what I found...
1) I Clicked on the Standard Dual PCI controller in Device Manager
2) Clicked on the Properties Button and found no settings tab.
Unfortunately, all there is, is a General Tab and a Resources Tab.
In the General tab area, there is a DeviceStatus and Device Usage area.
Note; I am using Windows95 v4.50a.
0
 
MrbreezeCommented:
Ramoore,
Here is a link to a file you need to download and install to get the controller updated. First though lets be sure you have an Intel chipset in that box. You will need to take off the case and look on the motherboard at the square chips on it. What you are looking for is writing on one of the bigger chips that says something like this
INTEL
PCIset
FW82371SB
there will be other stuff but that is enough.
Also one close to the processor that has
INTEL
82430VX
or similar

Let me know if you can find them
http://developer.intel.com/design/chipsets/drivers/busmastr/license.htm
                  Mrbreeze
0
 
ramooreAuthor Commented:
Mrbreeze:
Here's what I found (I am now entering outer space)...
The Large (System Controller chip?) is a VIA VT82C585VP
The other large (PCI to ISA Bridge chip?) is a VIA VT82C586
I found a web page that has all kinds of info pertaining to VIA, but I am kind of confused as to what to look for exactly.
the sites I found are:
http://www.fic.com.tw/techsupport/utilities/ficvia.htm
and
http://www.tomshardware.com/vp1.html
Can you guide me alittle more. Is it the controller upgrade driver I need?
0
 
MrbreezeCommented:
Ramoore,
Let me go look at the link but don't download the Intel link I gave you, it won't work
                       Mrbreeze
0
 
ramooreAuthor Commented:
Mrbreeze, I think we've went as far as we should go. You have done a super job narrowing things down. You answered my question, basically. I am happy with that. The Zip would have been nice, but thems the breaks. As far as upgrading to Win98, I'm not sure, considering the age of this PC. I do appreciate all the help.
0
 
MrbreezeCommented:
Ramoore,
I found the updated driver for your chip at the VIA site and thought I had sent it to you but somehow it didn't go through

Here is the driver

http://www.via.com.tw/drivers/580_2144.exe

And here is the readme file to explain how to install it

http://www.via.com.tw/drivers/bmreadme2133.txt

I think if you put these on you will be able to fire up that Zip.
                     Mrbreeze
0
 
ramooreAuthor Commented:
Thanks, so much. I give it one last shot.
0
 
MrbreezeCommented:
Ramoore,
It is frustrating sometimes but it is only a machine. The new bus driver should allow the Zip to work. The drivers you are using now was made 2-3 years before the drive and they aren't able to deal with it.

You could download them and install them later after you catch your breath, you worked hard. The goal is to do the best we can to remedy the conflict you are having, sometimes there is no solution but to give up, but now and again we can come through and beat the rascal.

Let us know how it goes and good luck.
                           Mrbreeze
0
 
ramooreAuthor Commented:
You are an expert in my book. We beat the rascal. I downloaded and installed the driver after a couple of tries and now the Zip works. An actual Zip icon with drive letter appeared on my desktop. I can see the files I copied to it. Whew! Thanks again!
0
 
biardCommented:
Bravo, Mrbreeze!
0
 
MrbreezeCommented:
Alright Ramoore now thats what we like to hear. Happy zipping and let us know if we can help again
                          Mrbreeze
0
All Courses

From novice to tech pro — start learning today.