Allusers Startup folder does not work

We are trying to configure our pc's so that a time sync program executes at startup, no matter who logs on.  We are running NT 4.0 workstn and server w/SP5.  This is a single domain TCP/IP network with 140 pc's.  If I log on as an administrator and place the previously installed program executable (nettime.exe) in the WINNT\Profiles\allusers\start menu\programs\startup folder and then log off and log back on as a different domain user, the program does not startup and it is not found in the Allusers startup folder.  If I log back on as the administrator, it is back in the allusers startup folder.

However, if I place the nettime.exe in the WINNT\Start menu\Programs\Startup folder while logged on as a domain user, then when I log back on as that user, the programs starts as it should.  If I log on as a different user, it does not start.

The object is to configure the computer so that no matter who logs on, the nettime.exe program will execute.  I thought that was what the allusers folder was for.  All other programs located in the allusers\start menu\programs folders do show up as programs in the start menu when anyone logs on, so that part of it does work.

One thing that I have noticed with these pc's is that, in the past, when we logged on as a domain user, that user profile was always expanded upon opening explorer (ie., WINNT\Profiles\username\.  Now when I open explorer after logging on as a domain user, the WINNT\Start menu\ is expanded, and not the user profile.  This appears to have something to do with the overall problem.  Any suggestions?
jack14Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
bantamsConnect With a Mentor Commented:
in user manager, under the profiles tab of each user, enter the program name i.e
nettime.exe as the logon script.

then save the nettime.exe file in the following location

c:\winnt\system32\repl\import\scripts

on the PDC, this should then execute the nettime.exe at logon.
0
 
jack14Author Commented:
I will give this a go - thanks
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
I think bantams idea is best, but another thing to try is adding to the the list of "RUN" programs in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
0
 
jack14Author Commented:
Great solution - Thank you!
0
All Courses

From novice to tech pro — start learning today.