[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 281
  • Last Modified:

Unresolved Symbols After Kernel Upgrade

Hello, I've been trying to upgrade RedHat 6.1 to the 2.2.14 kernel. I've dl'ed the kernel, and ran a make menuconfig which was based on a sample config file that came with the Redhat Source.

Did a make clean dep modules_modules_install bzImage , depmod -a 2.2.14

I copied overy System.map to /boot (Actually made System.map a symlink to System.map-2.2.14) and updated lilo.

The new Kernel boots, and even runs to a good degree, but I have about 50 modules that complain about unresolved symbols, including the MSDOS fs type module.

I'm running all this on a dual Pentium 3 500 , with only 1 CPU, 256 ram. I've tried compiling the kernel without SMP support, and with, but still these errors.

Does anyone know whats happening here?

Thanks,
Aaron McNeal
0
evileye011900
Asked:
evileye011900
1 Solution
 
patowicCommented:
It sounds like you might not have gotten all of the proper modules to recompile.  Verify that your config includes all the modules that are complaining of unresolved symbols.
0
 
moonbeam012200Commented:
It is common for distributions to pre-compile modules and
place these modules in the /lib/modules/`uname -r` tree.
If some of these modules are not enabled in your kernel a
depmod -a will result in some error messages.

The fix is to mv /lib/modules/`uname -r` to a backup (something like 'mv /lib/modules/`uname -r`  /lib/modules/`uname -r`-old' and 'make modules;make modules install' in /usr/src/linux.
0
 
dbenfellCommented:
I'm noticing the underscore character you used when stating the steps you followed.  Also, do the make clean before you do the configuration, not after.  I'm not sure what make clean does, but make mrproper will delete your .config file which holds the configuration.  For all I know, make clean might do the same.  Then the steps should be:

make dep
make bzImage
make modules
make modules_install

These can be combined into one line as:

make dep bzImage modules modules_install


Then, of course, copy the new bzImage into the /boot directory (or, depending on the distribution,) /, modify /etc/lilo.conf to add the new image and run /sbin/lilo.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now