Mounting Linux NFS partitions under AIX 4.3.3

I have a file system exported from my RedHat 6.0 Linux box and am trying to mount it on a box running AIX 4.3.3.  The error I get on the AIX box is

mount: 1831-010 server prime not responding: RPC: 1832-012 Program/version mismatch; low version = 2,  high version = 2

What do I need to do to get this to work?

Thanks,
Rich
rellehAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RobWMartinCommented:
relleh,

I don't know anything about AIX, but have you looked into the most glaringly obvious possibility:  that AIX uses DCE RPC, while linux uses ONC RPC.  They aren't compatible.  Is this the first attempt you've made at client/server stuff between your AIX and Linux boxen?  RPC based client/server stuff, that is.

Don't know what else it could be.  If so, though, I don't know of a patch/module for linux which provides DCE RPC service.  Maybe AIX has an ONC RPC solution; probably for the right $.

Rob
0
RobWMartinCommented:
One possible way to tell if AIX is using DCE is by monitoring the traffic (use tcpdump) and look for attempts to connect to TCP/UDP port 135 (DCE) or 111 (ONC).  

I really doubt this is the problem, as DCE was developed by Microsoft, while ONC is from Sun Microsystems.

Another possibility, I'm not sure if Linux talks ONC RPC versions 3 and 4.  I know it talks version 2 (i.e. Port Mapper Protocol).  Maybe, AIX is trying to talk 3 or 4, and Linux doesn't know what to do with it.  Thus the version related error message.  May be a simple matter of enabling Linux ( rebuild kernel, or twiddle /proc ?) to serve RPCBIND (i.e. RPC version 3 and 4).  I seem to recall seeing rpcbind in a log or ps output, so Linux must support it.  I think it may have something to do with the difference between transport independent RPC and the other one; can't remember right now what it's called.

Anyhow, I'm definitely not an authority on this subject, but I noticed you weren't getting any bites.  Thought maybe my limited knowledge of it could at least start you toward a solution.

Take it for what it's worth.

Good Luck!

Rob
0
ahoffmannCommented:
sounds like AIX's nfsd uses version3 NFS protocol, check man pages on AIX (mountd, automount, nfsd) how to force using protocol version2, probaly option -t nfs2, or nfs2 in /etc/dfs/dfstab (or similar)
0
flatsCommented:
Yeah dude, that sucks, I had the exact same problem about a month ago...and after a few days I finally found the answer after toying around with it.
Take these steps:

1.  On Linux server, make sure portmapper and nfs services have been started.

2.  To share a directory for a particular host type "exportfs -v HOSTNAME:/directory"

3.  For AIX, on the client end....
      In smitty use the following options for mounting a directory:

      Turn secure off (have not tested with security, it should work though)
      Remount file system: both
      Mount on restart: yes
      Mode : Read-write
      Number of times: 2
      Buffer size for read: 1024
      Buffer size for write: 1024
      NFS version: 2
      Transport protocol: udp

4.  As a result, the file /etc/filesystems should contain:

/directory:
        dev             = "/exporteddirectory"
        vfs             = nfs
        nodename        = HOSTNAME
        mount           = true
        options         = bg,hard,intr,retry=2,rsize=1024,wsize=1024,vers=2,proto=udp
        account         = false
 

5.  On the Linux server the file "/var/lib/nfs/xtab"  can be manually edited (this is a preferred method over /etc/exports)

The current file looks like this:
##
/rhat   aix.system.com(rw,async,wdelay,insecure,root_squash,no_all_squash,mapping=identity,anonuid=2,anongid=2)
/rhat   aix.system.com(rw,async,wdelay,insecure,root_squash,no_all_squash,mapping=identity,anonuid=2,anongid=2)
##

NOTE:  anonuid and anongid are the user and group numbers for who creates and owns nfs files.  I set it to user/group "daemon"


6.  If any changes are made to the file /var/lib/nfs/xtab type "exportfs -av" to activate them.

7.  If there is a continued problem mounting the directory use this command on AIX:
      "nfso -o nfs_use_reserved_ports=1"
      This will force AIX to use ports <1024
      This line can also be added to /etc/rc.tcpip so it runs at boot

8.  Any other questions can be answered by the How-to

      http://www.linuxdoc.org/HOWTO/NFS-HOWTO.html  

Good Luck,
Derek
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.