Not starting services automatically

I have an annoying problem.  RH6.0 used to start automatically from the point that I turned the power on to the point that it asked for my password.  I tried to add some memory to my machine (32MB chip), the computer said 81,???? MB (which is wierd) and tried booting up.  I got a bunch of errors on bootup and then it locked.  I took the memory out, now when I boot I get:

"Start Network service  (Y)es/(N)o/(C)ontinue?"

I have to hit "c" to start all the services.  Plus now I am getting some "bitfrm-0000 error = 2" messages when I boot, also when I try to run grep.

What happened?

Thanks.

-John
john2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

EatEmAndSmileCommented:
Are your RAM chips installed right? Maybe when you changed your configuration, you left some chips not well pluged. Check it out.

 Also, whenever you change your memory sets, run your BIOS Setup for it to detect your new amount of RAM.
0
john2000Author Commented:
I put the memory back the way it was.  So I think that something messed up when I tried to boot with the new memory.  What I think is, the motherboard probably needs 32MB chips in bank 1 and bank 2 (or possibly all 4).   I am not really concerned about this though.

I am wondering why I have to answer (Y)es or (C)ontinue to start my services now?  It is almost like a "safe" mode where I can choose which services start.  This is annoying because if power is lost, the machine will not start my services.

0
EatEmAndSmileCommented:
I believe this is happening because there's a fault on your system. Linux is probably reading somewhere that you have X mb of RAM and you actually have Y mb of RAM... I don't know, I'm guessing. That's why I think you should make sure your hardware is ok.
0
RetrenchCommented:
At the lilo prompt you can specify the amount of memory that can be used
by linux.

If you have 64 MB and your image is called 'linux', type the following
after the LILO prompt: linux mem=64M

If this solves your problem you can add:

append="mem=64M" into /etc/lilo.conf en compile your lilo again.

Greetings,
   RJ
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.