I/O error for Modem

I have an AMD K-62 266, SIS6326,128 MB, FIC 503+, & an Actiontec 56K Call Waiting PCI Modem. I've followed everything I have, but when I try to setserial it gives me an I/O error. I have double & triple check the I/O value 0xd800. Is it me, my hardware or what? I have tried RH 6.1, Caldera 2.3, S.u.S.E. 6.2, Slackware 7, TurboLinux 3.6,Linux Pro. I don't know if I'm an idiot or if this is a difficult question.
linux_user1969Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

moonbeam012200Commented:
It is my guess that the "actiontec" is not a real modem,
but rather one of those infamious "winmodems". Your best
bet is to cut your losses and get a real modem.

There is some support for supporting winmodems. Check out...
http://www.linmodems.org/
0
freesourceCommented:
According to actiontec your modem is supported by Linux:

http://www.actiontec.com/products/modems/cwi/index.html

Here is the product support page for this modem:

http://www.actiontec.com/support/modems/cwifaq.html

And here is the link you want to look at which shows you how to setup the modem for Linux.

http://www.actiontec.com/support/modems/cwifaq.html#installlinux

If you follow the directions you should be able to find the right I/O port and IRQ for your modem.  Make sure that serial support is compiled in your kernel.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
linux_user1969Author Commented:
It is a real modem. It is on the hardware compatibility sites. Thanks anyway.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

linux_user1969Author Commented:
I have been to to the site and they don't offer anything there that isn't in the manual that comes with the modem. How can I tell if the kernel is compiled for serial support? The mouse sets up fine. When I use # cat /proc/pci it sees the modem. It says it is at irq 10 and I/O 0xd800-0xd8ff
                                       I/O 0xdc00-0xdcff
                                       I/O 0xe000-oxe007
0
freesourceCommented:
According to actiontec your modem is supported by Linux:

http://www.actiontec.com/products/modems/cwi/index.html

Here is the product support page for this modem:

http://www.actiontec.com/support/modems/cwifaq.html

And here is the link you want to look at which shows you how to setup the modem for Linux.

http://www.actiontec.com/support/modems/cwifaq.html#installlinux

If you follow the directions you should be able to find the right I/O port and IRQ for your modem.  Make sure that serial support is compiled in your kernel.
0
freesourceCommented:
If the mouse is working then serial port is in the kernel.

Do a cat /proc/interrupts to see if another device is using the IRQ the modem is using.  For instance, I have a scsi adapter using IRQ 10 on my system.  If this is the case, you can change the IRQ assigned to the pci slot in your BIOS.  Generally, you get into the CMOS to adjust BIOS settings by pressing Del when you boot up your computer.
0
freesourceCommented:
Notes to the previous comment:

Actually,  your BIOS probably doesn't support assigning IRQ's to pci slots individually, but you may want to try disabling PNP.   If you do find a device using the same IRQ, remove it to see if the problem is resolved.  Also, check to see what your COMM settings are in you BIOS, maybe there is a conflict here.
0
freesourceCommented:
Oh!  You already accepted my answer :)
0
linux_user1969Author Commented:
Thanks for your help, I never thought of going to the BIOS. I'll look in to that and let you know. Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.