Multiple HDDs in a system

I have 2 harddrives in my PC in the following configuration:

IDE1 Master:  Maxtor 12.3GB
IDE1 Slave:   CD-ROM

IDE2 Master:  Quantum 2.1GB
IDE2 Slave:   ZIP internal 100MB

How do I specify which HDD is active, i.e. which one will get booted?  Somehow, now my IDE2 master is reported as disk1 and IDE1 master as disk2.
LVL 1
tomkynAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MrbreezeCommented:
Do you have an OS installed on both drives?
                         Mrbreeze
0
My name is MudSystems EngineerCommented:
Check the BIOS, in the Boot sequence, check that you have the right order for boot devices, normaly i would put:

1st boot device: FDD 1.44 disk
2nd boot device: HDD0 [this last digit is a zero, damn new look doesn't print slash zeros]
0
EDStechCommented:
Open the PC and verify which is plugged in where.

It sounds like the 2gb is plugged into chain(1).  If you want to reverse it, you need to change the physical cable connections in the pc.

You can't reverse HD's in the bios.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

MorescaCommented:
Your first recourse (though not necessarily a workaround) is to specify which drive your system will look to first when it boots via your BIOS.  This should work provided you have a bootable OS on that particular drive, I.E. IDE1.  You would specify the order in which your drives are booted; A:C:D, C:A:D, etc..
    As far as which drive is set as active, it is mandatory for Drive 1, at least as far as fdisk is concerned.  To assure that you actually have a startable drive you could run the `fdisk' command and choose option 2.  "Set Active Partition".  
***Be forewarned, though...inadvertently changing settings within fdisk and saving them will result in you either repartitioning and reformatting causing all loss of current contents of the drive or mucho money to a data recovery service to get it back.  (Unless you are VERY good with a HEX editor)***
Either the active partition is already set and an error will be displayed stating so or you will define the drive then.  These two points should get you on your way, unless I overlooked something.
0
MorescaCommented:
Your first recourse (though not necessarily a workaround) is to specify which drive your system will look to first when it boots via your BIOS.  This should work provided you have a bootable OS on that particular drive, I.E. IDE1.  You would specify the order in which your drives are booted; A:C:D, C:A:D, etc..
    As far as which drive is set as active, it is mandatory for Drive 1, at least as far as fdisk is concerned.  To assure that you actually have a startable drive you could run the `fdisk' command and choose option 2.  "Set Active Partition".  
***Be forewarned, though...inadvertently changing settings within fdisk and saving them will result in you either repartitioning and reformatting causing all loss of current contents of the drive or mucho money to a data recovery service to get it back.  (Unless you are VERY good with a HEX editor)***
Either the active partition is already set and an error will be displayed stating so or you will define the drive then.  These two points should get you on your way, unless I overlooked something.
0
MorescaCommented:
Forgive my dual post.  The page refreshed and opted to resend the data so I said OK, hence the two similar notes.  It's late.   :-/
0
pear49Commented:
the bios will boot ide1
your case is peculiar, it may be the case that you are using a dual boot program or something similar.
0
tomkynAuthor Commented:
Well, looks like my BIOS (Phoenix 4.0 rel 6.0) lets me chose which device should be tried for boot first.  Moreover, for each non-removable, it allows me to specify order in which IDE disks are booted, e.g. IDE1, IDE2, etc.
Thanks for all comments.
0
EDStechCommented:
Thats a heck of a bios... ;)

Maybe i'll try to flash that onto my award pc here.  You'd be amazed how often bios-flash-swapping works.  

Glad you got it fixed.
0
My name is MudSystems EngineerCommented:
So looks like i did say so??? do i have the points???
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mckingCommented:
May i know which hdd u got OS ?
If it's on the IDE2, then definitely the BIOS will skip IDE1 and then treat IDE2 Master as the one can boot.

Unless u let your hdd install invidually  and install a OS inside then u get choose a active on the partitions in your hdd else i dun think it's possible to mark 2 active while 2 hdd r installed .

0
martyn_bannisterCommented:
Tomkyn,

1) Big problem here that I think you need to sort out. If you have your Maxtor hard drive on IDE1 and also your CD-ROM on IDE1, then the hard drive will be slowed down to the max speed of the CD-ROM. You need to put both hard drives on one IDE channel so that they can get the most throughput.

2) Check the jumpers on the drives. One must be marked as a master and the other as a slave.

3) Check the Bios and make sure that the Primary IDE channel is the one marked for boot up.

4) Make sure the Master disk on the Primary IDE channel is bootable! i.e. it has an active primary partition and it has been formatted with the "/S" switch, or you have run the SYS command on it.

HTH

/\/\artyn :-)}>-===
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.