personal web server

Dear all,
   After I've installed the personal web server,it will automatically run each time I enter win98.How can I disable it?I find that if it is running,I cannot surf web pages,sometimes even cannot connect to internet!
LVL 2
hpchong7Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MrbreezeCommented:
Hp,
Hello again. If you are not connected to a network you don't need PWS. The best thing to do is go to is remove it, you can't disable it.  
Control Panel,Add/Remove Programs
Scroll Down to it, click on it and click the Add/Remove button.
                         Mrbreeze
0
gambisticsCommented:
It could be started from the Startup-folder or by the Run-key in the registry. You can find it at:
HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER/software/microsoft/windows/currentversion/run
There might be a value which starts PWS. I hope this helps
0
wistexCommented:
There is a checkbox you can uncheck that will prevent PWS from loading on boot (see option 3 below for this answer).  But it seems you have deeper problems if PWS is not allowing you to surf and use the PWS at the same time (see option 1 & 2 to try to solve this problem).  You should be able to use the internet & PWS at the same time without any problems.

I'm not sure of the exact reason why it won't allow you to surf web pages when the PWS server is on, but here are some possible solutions you should try if you haven't tried them yet:

Option 1) Uninstall the Personal Web Server
(This is an option if you don't need it.  If you need to use PWS, skip this and continue on.)

Option 2) Reinstall Personal Web Server.  Make sure you have the latest version, any patches and make sure virus checking isn't on when you install it.  Also, make sure the browser and any other internet program is running.  Sometimes different programs can interfere with each other or lock files and settings when open.

Option 3) Disable it in the Control Panel, and start it upon demand.  If this is what you want to do, go to the Control Panel and open Personal Web Server.  Click on the Start-up tab.  There is buttons to start and stop the PWS on demand.  But more importantly, there is a checkbox that says "Run the Web server automatically on start-up."  Uncheck that box.  That way it won't start everytime on boot, but you can always go to the control panel and start and stop it at will.

If the PWS is not allowing you to surf, something is messed up in the configuration somewhere.  I would recommend option 2 & 3 if you need to use the PWS.  Option 1 if you really don't need it.

Try the above options first and see what happens.  If that doesn't resolve it, or you continue to have problems with using PWS and the internet at the same time, it may be time for some surgery (editing the registry, etc.).  But editing the registry shouldn't be the first course of action in this situation.

I use PWS and the internet at the same time frequently.  In fact, I often use it to make additional backups of my web sites in FrontPage by publishing from the internet to the PWS (or vice versa).  I do have problems sometimes when I use the PWS and the internet, but it is actually a resource problem.  IE uses a lot of resources (and it leaks memory too), and PWS uses a nice chuck as well.  Together, they can hog up a lot of your resources.  It wouldn't hurt to check your resource level when you have all this stuff running.  A lot of funny things happen when you run low or out of resources.  If you suspect a resource problem, I can provide a way to check that.  But first, try the options above.  Then we'll know what to do next depending on the results.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

wistexCommented:
IMPORTANT CORRECTION TO TYPO ABOVE!

In option 2 I said: "Also, make sure the browser and any other internet program is running."  I typed so fast I forgot the word NOT!

It should say:  "Also, make sure the browser and any other internet programs are NOT running."

Amazing how one little word can change the entire meaning of a sentence.
0
gambisticsCommented:
>>But editing the registry shouldn't be the first course of action in this situation

That's right. If there's another solution I would prefer it, too. But when you delete the key which starts PWS at the time of start you can manually start PWS later and control so when you you like it to be started and when not.
0
wistexCommented:
That would be something interesting to look at.  What is the value of the key when the checkmark is check, and what is the value of the key when the checkmark is unchecked (if there is any)?  If the PWS startup value is stored in a key, then the checkmark in the Control Panel (in theory) must change the key.  

Unless it is using another method of starting the PWS on boot, which would then raise the question, why a key AND another method and how does the key get changed if the Control Panel checkbox doesn't do it?

I've successful prevented PWS from starting on boot using the checkbox and never had to touch the registry at all.  But hpchong7 seems to have deeper problems.  Hopefully surgery will not be needed but it is a possibility we will need to mess with the registry on this one.  We'll just have to see his results to know for sure.
0
hpchong7Author Commented:
Dear all,

     Thank you for so much great answer!Finally I've solved it!I make a careless mistake and now all things are okay!Thank you all of you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.