PPP in RH 6.1

Well, I finally got my modem to dial and connect. now I can't get anywhere in the browser. Basically I get "no DNS entry" errors for all sites. I did enter my DNS info (primary and secondary DNS) in the Internet setup dialogs. I can't find anywhere to enter any other info. I'm running Gnome desktop, modem is a USR Sportster V90 internal.
capttomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

freesourceCommented:
Edit the resolve.conf in the /etc directory.  Enter the nameserver you use like this in this file.

nameserver 192.168.1.1

192.168.1.1 should be replaced by the nameserver your Internet provider uses.  But, you can also put other nameservers in the list, and if for some reason your Internet Services nameserver fails the next nameserver in the list will be used.  For more information about this read
NET3-4-HOWTO which provides more information about the resolve.conf file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
freesourceCommented:
I should point out that resolve.conf is really spelled
resolv.conf.  So edit /etc/resolv.conf not /etc/resolve.conf, I just spelled it like it sounded in my mind.  
0
capttomAuthor Commented:
OK, I checked the file. The only info in it was:

search localdomain

Should I leave that in and put the others above it or should I remove that entry?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

freesourceCommented:
You can comment out the line like this:

#search localdomain

Unless, you are using your machine as some sort of network server, and you need to tell clients accessing your server when they can't find your hostname in your domain that they also should try the localdomain domain.  If you don't serve a network, it probably shouldn't hurt one way or the other, unless there is a program on your machine which depends on this line, which is probably unlikely.  

But, this is definitely your problem.  You do need a line like:

nameserver 204.225.44.10

But, use the nameserver your Internet Provider gave you first.   You can put this line above or below the "search localdomain" line.
0
capttomAuthor Commented:
OK. Will try it as soon as I get home. I agree that this the answer but it seems odd in that I did enter this info into the dialog box that asked for it in Internet settings. seems it would have written to this file.
0
capttomAuthor Commented:
OK, last question on this (i hope...)

I want to put both my ISP's nameservers in there so would my final file look like:

search localdomain
nameserver 204.225.44.10
nameserver 204.225.44.11

One line per item and "nameserver" on each line?
0
freesourceCommented:
As for your most recent comment, the answer is "Exactly!"

And for the comment before that, I agree with what you are saying.  It is strange that the file wasn't written to. I assume you pressed the save button after you entered the information?
0
capttomAuthor Commented:
It worked perfectly. thank you.
0
freesourceCommented:
As for your most recent comment, the answer is "Exactly!"

And for the comment before that, I agree with what you are saying.  It is strange that the file wasn't written to. I assume you pressed the save button after you entered the information?
0
freesourceCommented:
As for my most recent comment, I accidently reposted the form which I sent the previous comment on, thinking I was just looking at this page :)

I am glad it worked for you.  Have fun surfing!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.