I can not get DNS to work for Dial-up connection

Hello,
I have just installed RH6.0 and I am trying to get my dial-up to work so I can browse the Internet. I am able to connect and bring up pages that I know the IP address of but not able to browse by name. I tried to setup everythinig by going through all the config files, but could not get that to work. Now I am using xisp, and it seems to work, just not DNS. any ideas?

forgive me for being a linux newbie :)
Cliff
cliff_mAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jebrightCommented:
You need to add (or modify) and file in /etc called resolv.conf

open /etc/resolve.conf and add the following:

domain <the domain name of your isp>
nameserver <the IP of the primary dns server for your isp>
nameserver <the IP of the secondary dns server for your isp>
search <the domain name of your isp>

for example, mine is:

domain your-way.net
nameserver 199.2.252.10
nameserver 192.168.1.1
search your-way.net

(note, this will ot work for you)

Then give it another try,

if it still does not work then edit /etc/nsswitch.conf
and look for a line called hosts

make is look like this:
hosts     files dns

Save this file and try again. You may need to redial before these changes will take effect. If your resolver cache has been corrupted you may need to go to single user mode and back to multiuser mode (or just reboot) to fix this.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jebrightCommented:
ooopss, typo, that file is /etc/resolv.conf not /etc/resolve.conf  :-)
0
cliff_mAuthor Commented:
Seeing how I am typing this while running Linux, I think I can safely say that your solution worked. Thank you for your help.
Now I have a fighting chance to learn more about Linux, because I don't have to reboot into Windows to find the answer. :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.