Telnet from win98 to linux is very slow.

I have set up my linux box as a server and connected a win98 machine to it. I can ping linux but when I try to telnet or ftp, it does connect to linux but I am not prompted for a username/password, it's takes a couple minute then it asks me for a username.
So every time I want to telnet I need 5 minite just to connect. I thaught of a slow network, but once I telnet to linux, the conenction seems very fast.
can any body help on, I spend a lot of time on this.
Who is Participating?
karim1Connect With a Mentor Commented:
I will assume that you have a small network at work to answer this question:
if you are using to real ip's the problem could be that the computer is first going to the gateway and then connecting to your linux box.
What I did to solve this problem was to create a routing table, so my windows box can connect directly to my linux box, without going through my school's gateway or the DNS server.
tell me if this is what you need so I can send you detail information on it.

chakibAuthor Commented:
Well , I have only two machines. I did specify in win98 the gateway is the linux box. they are not connected to any network. small network with two PCs.
  The question is , it connects to the server very fast, but it take a while to get me the login prompt ?
try using another telnet program, like ewan.

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

chakibAuthor Commented:
The problem was with my resolv.conf file. I am using my linux box to connect to an ISP. When it's not connected it tries to check the DNS which it can't connect to it, so it keeps trying.
I have to delete the resolv.conf file if I am not connected to my ISP. no other choice .
I have seen this problem in the past with several of my customers, it is due to a poor DNS setup, check your DNS settings on the client side and the server side to make shure names resolve properly.
if your using redhat run startx, open menu, system, control panel, networking, hosts, and add the ip & domain details of your other machines, works for me, I spent all day messing about & reinstalling, I think the other option is to set up some sort of automated dns thing, might try that tommorow, anyway my time went down from 1min to instant when telneting & ftping
Thanks chakib! I had a problem with some old settings in my resolv.conf. Your question and comment saved me much time.
Fixed the -1 problem on this question.
Escrow points corrected.

Community Support Moderator
Experts Exchange
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.