• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2485
  • Last Modified:

Crystal Report Problems - crviewer.dll not registering correctly

I'm trying to install a vb6 app on a new machine.  the program includes crystal reports created using the report design component and they are viewed using the smart viewer.  

i've been unable to view the reports on the client machine.

i get an error 339 - crviewer.dll or one of its dependencies are not registered correctly.

i've checked to make sure that all of the required files exist on the client machine.

among the seagate support suggestions is that two files, urlmon.dll and shlwapi.dll must be the same version.

i don't understand this since i do not have the same version of these files on my machine and am able to run the reports.  

anyway two questions:
does anyone know of another workaround for this problem?


how do i go about getting matching versions of these dll's?

1 Solution
This is a Simple Problem , all u hv to do is just uninstall crystal report and also delete the file physically from the drive and then use regclean ( free down load from microsoft)
then install again the problem will be solved
laurapAuthor Commented:
thanks i will try this.....just to clarify.....

are you saying to do the above to the development machine?

because the client machines do not have crystal reports installed on them.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now